StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
529 Posts
Discussion Starter #1
My bike has had the FI light come on twice. It would go off if turned ignition off and back on.
Brought it to my dealer, and they read the ECU error code. It said it was a exhaust butterfly issue. Cables needed to be adjusted. They told me that it's not under warranty, and that it was routine maintenance on this bike.
Sounded fishy to me, so I looked in the manual under maitanece schedule, and there was nothing about adjustments to exhaust butterflies.
Think I'm going to call Suzuki. Anyone else had this issue?
 

·
Registered
Joined
·
528 Posts
Haven't had that issue, but good luck with Suzuki. I had an issue with the rear axle/nut galling on my 650 at 10 months. Apparently, a not uncommon thing on the bike. I had to use a long pipe for leverage and all the strength I had to get that nut off. Of course the threads were totally destroyed, but the only other alternative was to cut it off. Took the axle and nut to my dealer, said they never heard of it, but sent it in to suzuki. Suzuki said "user error", that I stripped it. Needless to say I was f'n pissed.
 

·
Registered
Joined
·
209 Posts
I have the same issue...The FI light comes on, it has happened maybe 5-6 times now...Shut the bike off, then back on, light goes away...Good to know that it's just the butterfly valve on the exhaust, if that's the case, no big deal...
 

·
Registered
Joined
·
246 Posts
It can't be that hard to adjust a couple of cables.
I imagine it would not be dissimilar to adjusting throttle cables.
A wee bit of free play on both cables with full range of movement of the butterfly.
 

·
Registered
Joined
·
529 Posts
Discussion Starter #5
Just so stupid. But problem is fixed. Now I know. Wish they something in manual to tell you about it. 105 bucks later. Maybe I can save some forum members some headaches in the future.
 
1 - 5 of 5 Posts
Top