StromTrooper banner
1 - 4 of 4 Posts

Registered
Joined
116 Posts
Discussion Starter · #1 ·
I remember seeing an error code list, l did a search but couldn't find it, it may have been on a different site. But since I'm getting old and senile I can't remember 馃槼 anyway if someone could point me in the right direction I'd appreciate it.

For a 2009 Wee
Thanks
 

Registered
Joined
553 Posts
Here are my notes. Codes are at the bottom:

User Mode (normal running mode): if an FI error occurs you will see the "FI" letters displayed in the odometer readout area. If the FI is alternated every 2 seconds with odometer readout & the Red FI lamp on the dash is on solid, the bike will start and run in fail-safe mode. If the odometer readout is FI & the Red FI light lamp is blinking, the bike will not start.

Dealer Mode: An FI error will be memorized in the ECU when an error is present. This error will stay in the ECU as long as power is not removed from (battery disconnected or ECU unplugged) the ECU and the error has not been cleared. It should be noted, that if an FI error is intermittent, the error code should be checked before the bike is turned off. Carry a spare key & a jumper so the seat can be removed and Dealer Mode entered while bike is still running. As soon as an error is cleared it is removed from ECU memory. You can run the bike as normal when in dealer mode. If you are dealing with an intermittent problem, wire it for dealer mode and ride. The code will show when the FI light is on. If the error clears, so will the code.

Dealer Mode Engine connector is under the left side cover behind the seat latch. Remove the connector cover to access the connections. It has a 6 pin plug with four wires. The White/Red & Black/White wires are the ones you will jumper to enable dealer mode. In the 6 pin plug they are the ones on the end.

The Dealer Mode ABS connector is located under the left rear fairing next to the ECU. The smaller one with a soft rubber cover is the dealer mode plug.



C00 No error

C11 Camshaft Position Sensor (CMPS) - 1000 Only

C12 Crankshaft Position Sensor (CKPS)

C13 Intake Air Pressure Sensor (IAPS)

C14 Throttle Position Sensor

C15 Engine Coolant Temp. Sensor (ECTS)

C16 Vehicle Speed Sensor Circuit (Front) Malfunction

C17 Intake Air Pressure Sensor (IAPS) - 07 & Up 650 Only

C21 Intake Air Temp. Sensor (IATS)

C22 Atmospheric Pressure Sensor (APS) - 1000 Only

C23 Tip Over Sensor (TOS)

C24 Ignition Signal #1 (Front Coil)

C25 Ignition Signal #2 (Rear Coil)

C26 Ignition System #1 (Side) Malfunction

C27 Ignition System #2 (Side) Malfunction

C28 Secondary Throttle Valve Actuator (STVA)

C29 Secondary Throttle Position Sensor (STPS)

C31 Gear Position Sensor (GPS)

C32 Injector Signal #1 ( Front)

C33 Injector Signal #2 (Rear)

C40 ISC Valve - 07 & Up 650 Only

C41 Fuel Pump Control System (Fuel Pump Relay)

C42 Ignition Switch Signal (Anti-Theft)

C44 Heated Oxygen Sensor (HO2S)

C46 EXCVA Sensor Circuit Malfunction

C49 PAIR Control Solenoid Valve

C60 Cooling fan relay circuit malfunction

C62 EVAP system purge control solenoid valve circuit malfunction

C64 HO2 Sensor #1 Heater Circuit Malfunction

C65 Clutch lever switch issue or Idle speed malfunction (can be caused by any fault that takes the idle speed out of range, TPS and GPS faults for example)
1) Turn the ignition switch to the OFF position.
2) Remove the seat.
3) Put the bike in dealer mode
4) Turn the ignition switch to the ON position.
5) Turn the ignition switch to the OFF position.
6) Then, wait more than 5 seconds.
The ISC valve automatically is set at the PRE-SET position.
7) Take the bike out of dealer mode.

Idle should be at ~1300rpm again.

C91 Vehicle Speed Sensor Circuit (Rear) Malfunction
 
1 - 4 of 4 Posts
Top