StromTrooper banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
My 06 DL650 has started having a stumble or hesitation at idle. Runs fine under a load but while idling at stop lights or just sitting, the engine will stumble or hesitate. Occasionally it will die. Starts again with no prob. 5,000 miles. Any ideas?
Thanks,
 

·
Premium Member
Joined
·
4,451 Posts
Braz, what is your idle speed(RPM) ? Maybe it dropped off a bit. Maybe a tank of bad gas ? Probably something simple. Good luck.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Stumble

Idle speed is about 1400. Just installed an Audiovox Cruise last weekend. Had not noticed this before that but everything works well other than the hesitation.
 

·
Registered
Joined
·
369 Posts
Not sure if it helps but I had a similar problem right after I installed my Audiovox. However, my bike was winterized with Stabile in the gas tank and this thing went away after 4 or 5 starts and I attributed it to the bike's system working itself out after months or non-use. It could also be that you have a leak in the pressure hoses that were connected to your Audiovox.

Wingman
 

·
Premium Member
Joined
·
4,451 Posts
Hey Braz, I had a thought about the stumble etc. Was the idle speed always about 1400 or a little lower as the manual recommends ? And does the cruise control have a vacumn control of any kind ? A vacumn leak would or could raise the RPM a bit and the lean mixture might be enough to upset the Wee. Of course I could be totally wrong and leading you astray. Keep us informed, I want to know what can upset such a nice running power plant.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
There is a vacuum canister on it with a check valve. All the hoses have been checked and appear to be well seated. Weird. Please keep the thoughts coming.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
Tapped screw. The air cleaner might be somethingto check. Thanks,
Don
 
1 - 8 of 8 Posts
Top