StromTrooper banner
1 - 20 of 32 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Getting a stutter when I accelerate or cruse in between 3.5k-4k regardless of gear is only happening when rpm is in between 3500-4000rpm. Any idea what can cause this stuttering?
 

·
Registered
Joined
·
1,856 Posts
This is a well known issue/feature of the 1000... Many, many others have complained of this... There are many apparent fixes that people are trying (have tried)... TB sync, TPS adjust, Power commander, voodoo...etc... I fixed mine (when I owned a 1000 years ago), by selling it and getting a Wee....
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Never, the bikes have only 14k and I thought that with such low mileage there is no need for adjustment of TBS?
 

·
Registered
Joined
·
6,709 Posts
TBS is like a every few thousand adjustment or when needed

Many 1000 bikes reported to be wildly off as delivered with the idea the Factory service at 600 would pick it up.

Do it and then extend the hoses --- join the club

I will next week now with fresh gas be all into the 2ndaries then TBS

I also did tre and teka box from the alternate forum


and the universal answer to all automotive operating difficulties

SEAFOAM
 

·
Registered
Joined
·
33 Posts
Go buy a power commander 3 and get a decent map from the pc3 thread on here. The problem is that the bike does not get enough fuel at those RPMs.
 

·
Registered
Joined
·
2,434 Posts
My 07 is UNridable between 2500 & 3000,it coughs and spits if you try to hold it there.If you acc thru it it's fine.


Sent from my Motorcycle iPhone app
 

·
Registered
Joined
·
24 Posts
Go buy a power commander 3 and get a decent map from the pc3 thread on here. The problem is that the bike does not get enough fuel at those RPMs.
This. And a tbs.
 

·
Registered
Joined
·
10 Posts
07 DL1000

My 2007 does the same thing. Wasted several hundred dollars at the dealer "fixing it" with no luck. I just keep the tach around 6 as much as possible and it works fine.
 

·
Registered
Joined
·
1,355 Posts
My 07 is UNridable between 2500 & 3000,it coughs and spits if you try to hold it there.If you acc thru it it's fine.


Sent from my Motorcycle iPhone app
Wow, that's BAD! I never heard of one that bad. I bought a TFI instead of the more pricy and complicated Power Commander and its the easiest to set up:
Adjusting the TFI controller

I wrote down my settings and tucked it in with the tfi which is mounted with velcro in the tray next to the battery, along with my aux fuse block for it and my other accessories. The TFI has been a godsend, no more fueling issues at all. I keep everything balanced and it's been a dream to own!

jeff
 

·
Premium Member
Joined
·
1,613 Posts
vibration

Just change gears and ride. It's a feature of big V twins; my mechanic says they all vibrate at some specific rpm and the Suzuki designers just conveniently dropped it in at about 3800.
 

·
Registered
Joined
·
319 Posts
Getting a stutter when I accelerate or cruse in between 3.5k-4k regardless of gear is only happening when rpm is in between 3500-4000rpm. Any idea what can cause this stuttering?
I went through the exact same thing.....tried everything. No, it's not "chuder"...no, a TPS adjustment and TBS won't do anything.

THE answer- you're running lean in that range (VERY common), so it stutters. If you're running high-ethanol fuel, it'll make it worse. It'll feel kinda like hitting the rev limiter and will go away exactly at 4k rpm. THE solution- buy a power commander and add as little as 5% more fuel in the range below 4k and throttle positions less than 50%.

It'll be cured, INSTANTLY. :thumbup:
 

·
Registered
Joined
·
608 Posts
I have an '08 Vee and had the same exact problem (as many other have also). As others have said, the issue is that the bike is running lean between 3-4K RPM. I believe this was done intentionally by Suzuki to meet EPA requirements. Throttle body synch may help, but for me the answer was the Power Commander. By enrichening the fuel mixture in the 3-4K RPM range, my bike now runs like a completely different machine. To be honest, I was seriously thinking about selling the bike before I installed the PC, but I am convinced that this change addressed all the stuttering and rough running in that RPM range. I wasn't happy about spending the money, but the boost in performance and improved runnability was well worth it!
 

·
Registered
Joined
·
86 Posts
Hey Krakone,

If you are going to do the sync, spend a few extra bucks if you can and get new spark plugs (if you havent already). Sufficient oxygen, spark and fuel leads to good times :)
 

·
Registered
Joined
·
1,160 Posts
This is a well known issue/feature of the 1000... Many, many others have complained of this... There are many apparent fixes that people are trying (have tried)...
TB sync,
TPS adjust,
Power commander,
voodoo...etc...
I fixed mine (when I owned a 1000 years ago), by selling it and getting a Wee....
I'd say CanadianFZ6 has hit the nail on the head with that reply. :mrgreen:

As for your bike stuttering. . .
Like the crew here mentioned, whether your bike is old or new you should do the TPS, primary TB vac-sync, secondary TB gap-sync, rubber boot check, etc... so you have a healthy baseline to troubleshoot from.
Lord knows, you'll need it.

Welcome aboard krakone!
-Ej-
 

·
Registered
Joined
·
2,361 Posts
Forget the BS about buying a 650 unless you are cool with less HP. The fix is simple. The bike is fine, its just EPA lean.

1) If you plan to ever mod the bike with exhaust, high flow air filter or cam changes...neither are needed by the way. Get a Power Commander and remap the off idle settings. This takes some trial and error but maps exist for the bike.

2) I have no need to mod my bike. So, I took it to a dealer with a dyno and had them remap the EFI with a Yosh box. It reflashes the EFI curves in the ECU. But, it will need another reflash...maybe, if you change stuff.

This cost me $150 well spent dollars. Now my 1000 runs like a 650 with 2 motors. And gets less gas mileage now....about 33 mpg from 36 stock.

Fortunately for the 650 fans, their bikes are mapped better from the factory.
 

·
Registered
Joined
·
41 Posts
TBH here lads I find it outrageous that Suzuki are allowed to sell bikes to customers in this state..

My 08 V is driving me NUTS..I don't even wanna ride it at all..it's not just the 3.5-4k stutter it trying to hold steady revs at all below 4k..crazy...above that is fine and it does rev cleanly from 0 right through..city riding is awful :(

Have tried two garages now for re map, throttle bodies etc..with no success..

Have straight through venom cans on it (which I love) and am gonna stick standard pipes on to see results..
Don't wanna go for PC as it costs €0000s and also ups mpg...so..may need new bike..
Really a shame as otherwise I really LOVE the V...
 
1 - 20 of 32 Posts
Top