StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello,
I am new to this forum and I am looking for some help in New Haven county CT.
I have a 2004 DL1000 with 18000 miles on it. At this time the bike will not run. The bike will start then dies. The problem is that after startup the fuel pump relay shuts off. The bike is at an independent shop in North Haven, the mechanic can get the bike to run by "tricking" the fuel pump relay. He is not sure why the relay turns off, at this point he is leaning toward the ECU. This part is had to find and expensive. I was wondering if anyone the CT area would be willing to meet at the shop and let the mechanic swap out the ECU with one that is know to be working to see if that is the problem before I purchase a new ECU. I you can help please reply to this post Thank you
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,048 Posts
That's a strange symptom. It's normally a problem with the kill switch or the side stand switch that shuts off the fuel pump. Does the bike shut off when it is shifted into gear or when the start button is released?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Hello Greywolf,
Thanks for the reply. It is taken me a little time to figure out how to use this forum. My mechanic did not have a service manual for this bike (not many vstrom so in CT) I found one one eBay. He then got busy with another bike and has not worked on my bike in a while. Borrowing a ecu was just a thought before purchase. My mechanic does not like to just start replacing parts unless he knows they are bad.
Thanks
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,048 Posts
Can you answer the question? Does the bike shut off when it is shifted into gear or when the start button is released?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
With ignition on, turn on kill switch and fuel pump relay clicks, bike starts and runs for a sec or two, relay tuns off and bike dies. The mechanic has tricked the relay to stay on and bike runs fine. The dash is giving the flashing F1 light. We checked the codes and we get C00, no fault codes, but can not clear flashing red light F1.
Bike ran fine before this, had dead battery and bike would not run after replacing battery. Do not know if battery change was causative or is issue a coincidence.
 
1 - 5 of 5 Posts
Top