StromTrooper banner
1 - 2 of 2 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
My wife and I just returned from a 1900 mile jorney down Skyline Drive and the Blue Ridge Parkway, riding the dragon's tail and riding back to PA. While taking a detour around Mt. Mitchel due to snow and ice on the parkway, I pulled over and shut down to confirm we were on the right road. When I went to start back up, nothing. The pumps kicked on when the switch was turned on, but no action when I hit the starter. To make a long story short, 2 hours of trying all i could think of, I decided to jump out the clutch safety switch. I unhooked the plug, stripped back the wires and twisted them together. The bike started! I did experience the bike stalling on occasion as I would down shift at lower speeds. I ordered a new switch and tore the old one out. The switch looks like it should slide side to side. This one failed by pulling sideways instead of sliding, not alowing the switch to make contact. The local dealer is supose to have a new switch later this week. I am hoping the stalling issue subsides when I install the new switch. My bike is an 07 Wee with 45,000+ Miles.
 

·
Registered
Joined
·
15,911 Posts
The switch is a known funky bit. Mine isn't right after replacement. I may not have gotten the switch properly placed during installation or adjusted properly. I can start the bike with a lurch with the clutch engaged. Won't start with the clutch engaged in neutral. No big deal.
Just one of the safety things to save us from ourselves.
Have your dealer install the switch, then you will be assured of the proper function of it...with a warranty!
 
1 - 2 of 2 Posts
Top