StromTrooper banner

1 - 4 of 4 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter #1
Has anyone else had trouble with this switch. I went to leave work today and my bike would not start. After some troubleshooting, I unplugged the switch and shorted the 2 leads together with a paperclip. Bike fired right up. I am going to call the dealer tomorrow to see if I can get it replaced under warranty, but I wanted to see if anyone else had any issues with this?
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,048 Posts
I haven't heard of any problems. The switch was changed in 2010 as the old switch allowed the wires to fall off too easily. Is your clutch lever stock? Don't try permanently bypassing the switch. The ECM includes the switch condition in setting the system.
 

·
Registered
Joined
·
242 Posts
Discussion Starter #3
I haven't heard of any problems. The switch was changed in 2010 as the old switch allowed the wires to fall off too easily. Is your clutch lever stock? Don't try permanently bypassing the switch. The ECM includes the switch condition in setting the system.
Lever is stock. Plunger for the switch goes through the entire range of travel with the lever. I found out about the bypass thing, I left the paper clip in for a couple miles and the FI light came on. When I removed the paper clip (after bike was running) and the FI light went out.

Is this something that should be covered under warranty?
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,048 Posts
1 - 4 of 4 Posts
Top