StromTrooper banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have 2007 wee strom with about 20 k on it .i started to hear an intermittent chirp now and then around the instrument panel.Tonight There was a couple of loud squalls then quiet. I am thinking its the cable for the Tac or speedometer . Anyone have a suggestion on how I can lube the cable if thats the problem or would it have to be replaced ..... Thanks
 

·
Registered
Joined
·
89 Posts
RE: Chirping Sound

Our bikes have no "cable" for the speedo. It is a wire. The chirp is from the sending unit. Repack it with wheel bearing grease. That means fill it up with the stuff. Chirping noise will be gone. Thank you GW.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,049 Posts
I think it's amazing that people invariably call the noise from a dry sensor a chirp. Anyhow, the sensor has an inner and outer part. Separate the two and grease the interface.
 

·
Registered
Joined
·
7,437 Posts
It takes just a very light film of grease on parts that aren't supposed to touch but sometimes do touch--thus the intermittent noise.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks for the advise on the speedometer noise .not positive what to take apart to lube it , maybe you tube ?.
 

·
Super Moderator
Joined
·
13,056 Posts
What isn't being said is that the sending unit is on the front wheel assembly. From a rider's point of view it is in line with the dash so it sounds like the sound comes from there. If you keep riding without lubing it the chirping sound will gradually get worse.

If you look at the left side of the front wheel axle you will see it sitting there with the wires running out of it. You need to take off the front wheel to get to the unit as the axle runs through it. The sender splits in half and needs a good shot of grease. You also need to make sure you put it on correctly so that it doesn't spin. Other more technical minded members can tell you of the size of the hex head needed and give other tips but it is pretty easy to do (if you have a centerstand.)

..Tom
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Lubed the sender per your guys input.Chirps gone , again thanks , and appreciate the detail Tom.
 
1 - 8 of 8 Posts
Top