Strom Trooper banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
**I already posted it here - but do not know how to close it and this seems like a more appropriate place** My Sincere apologies for duplication.

Hi,

A newbie here and request you to help me out with this issue I am having with my 2019 V-Strom 650XT.

Issue - error code C 12 (Doctor VStrom's you tube video used to identify the error code - his video also shows the explanation of the error as - The signal doesn't reach ECM for 2 seconds, or more, after receiving the starter signal)

Symptom -
1 - F1 and Odometer reading alternately show up.
2 - Malfunction indicator light comes on and remains lit.
3 - Engine comes on and runs on idle and the bike rides too.
4 - The issue started last week immediately after a friend of mine' father decided to water the bike while watering his plants - cause he thought it was a bit DUSTY. When I came out of his house and tried to start the bike - the F1 error was there. Though I am not sure if that was what caused it.

I recently went on a 1800 odd KM ride around a couple months back - to some remote parts of Himalayas where fuel is not the best quality, however I have been riding it since for around a month, as the service wasn't yet due - if this information matters - in case of a fuel injection related issue???

I have scheduled a check-up with the dealership workshop here, but they have the tendency to come up with ridiculous theories and eventually charging a bomb. Could you please educate me on what this means and what could the potential fixes be, so they can't take me for a ride, or even if there is a simple enough fix that can be performed by someone who is as raw as raw can be with this bike's mechanics.

**Can I ride it for about 50 Kms to the dealership or should I get it towed?

Also found this one on one of the C12 troubleshooting posts - posted by Hatchi -

"Dealer Mode::| An FI error will be memorized in the ECU when an error is present. This error will stay in the ECU as long as power is not removed from (battery disconnected or ECU unplugged) the ECU and the error has not been cleared. It should be noted, that if an FI error is intermittent, the error code should be checked before the bike is turned off. Carry a spare key & a jumper so the seat can be removed and Dealer Mode entered while bike is still running. As soon as an error is cleared it is removed from ECU memory. You can run the bike as normal when in dealer mode.:| If you are dealing with an intermittent problem, wire it for dealer mode and ride. The code will show when the FI light is on. If the error clears, so will the code."

Does this mean that I just need to remove the battery and see - if the error code goes away? He says that "if an FI error is intermittent, the error code should be checked before the bike is turned off", in my case the F1 error shows up every time I switch on the bike, does that mean anything?

***If the F1 code does disappear post the battery removal, is it a safe thing to do or is it just procrastinating an impending doom situation? I mean should I try this battery removal thing or should I just take it to the dealer post getting educated?

Thanks!
 

·
Registered
Joined
·
254 Posts
C00 No error
C11 Camshaft Position Sensor (CMPS) - 1000 Only
C12 Crankshaft Position Sensor (CKPS)
C13 Intake Air Pressure Sensor (IAPS)
C14 Throttle Position Sensor
C15 Engine Coolant Temp. Sensor (ECTS)
C17 Intake Air Pressure Sensor (IAPS) - 07 & Up 650 Only
C21 Intake Air Temp. Sensor (IATS)
C22 Atmospheric Pressure Sensor (APS) - 1000 Only
C23 Tip Over Sensor (TOS)
C24 Ignition Signal #1 (Front Coil)
C25 Ignition Signal #2 (Rear Coil)
C28 Secondary Throttle Valve Actuator (STVA)
C29 Secondary Throttle Position Sensor (STPS)
C31 Gear Position Sensor (GPS)
C32 Injector Signal #1 ( Front)
C33 Injector Signal #2 (Rear)
C40 ISC Valve - 07 & Up 650 Only
C41 Fuel Pump Control System (Fuel Pump Relay)
C42 Ignition Switch Signal (Anti-Theft)
C44 Heated Oxygen Sensor (HO2S)
C49 PAIR Control Solenoid Valve
 

·
Registered
Joined
·
468 Posts
Does this mean that I just need to remove the battery and see - if the error code goes away?
My experience has been that error codes don't clear by simply unplugging the ECU or disconnecting the battery. There is a short process that includes (if I remember correctly) riding a few miles, putting in dealer mode, and turning ignition key on and off. If you search through my posting history from summer thru winter of last year you'll find where I listed the processes which I believe it came from the service manual.

Good luck.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks @brock29609 - I found the post you were mentioning. So just to get a nod on whether or not I got it right (I have been getting a lot of things wrong);

1 - I ride the bike a bit around 50 odd miles.
2 - Stop the bike, put it in diagnostics mode, and switch the bike on and off (does that also mean start it or just switch it on and off)?
3 - AND by 'switching on' we mean - turning the key on + turning the engine kill switch on - so the bike runs thru the initial diagnostics right?

I apologize for being so ridiculous, but it seems, there is a bit of a moto-lingo gap between our countries. So just want to ensure I got it right!

Thanks again!
 

·
Registered
Joined
·
468 Posts
So just to get a nod on whether or not I got it right (I have been getting a lot of things wrong)
50 miles isn't necessary. I think the last time I cleared a code my ride was closer to 10 miles. Just use the key to turn the electrical power on and off. I don't think it matters what position the engine kill switch is in. If the code doesn't change to C00 in dealer mode, meaning all clear, the problem hasn't yet passed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
@brock29609 - Hey so it worked, a little differently for me, but it did.

Around 40 Odd Kms, I switched off the bike, plugged the dealer mode and switched on and off, as you said, nothing. Tried the same thing with the engine kill-switch on and off, nothing. Started the bike, with the dealer mode on VOILA - error code clear, C00. Brilliance! Ecstatic me - jumping up and down in the middle of the road at 45 degree Celcius, people thinking I am nuts!

Thank you @offnote and @brock29609 for helping me out this was brilliant and very patient of you guys!
 
1 - 7 of 7 Posts
Top