StromTrooper banner

1 - 4 of 4 Posts
J

·
Guest
Joined
·
0 Posts
Discussion Starter #1
For some odd reason the brake lights on my 650 Strom decided to quit working. The taillights are on so I doubt if its the bulbs. Both front and back brakes are not working. Since the fuse involved sereves multiple purposes I'm sure its not that.
Anyone encountered this one yet?
I imagine its going to the dealer tomorrow since its under warranty. Heck this is claim number two in just about 2k miles. Beginning to think there is more similarity to my BMW than I thought. :lol:
 

·
Registered
Joined
·
441 Posts
Joe,

Have you inspected the bulbs? The brake and tail lights use separate filiments. Yeah there are two bulbs and what's the chance they could both be burnt out? I dunno but crazier things have happened. I'd pull both bulbs and ohm them out to see if you have continuity through both contacts. If they are good, I'd test for voltage at either or both socktets with power on and either brake applied.

You could of course let the dealer fix it and probably should but I am one of those guys who's too curious to wait long enough for the dealer to get around to it.

Good luck in any event, you gotta have brake lights! Ride well,

Jeff
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I didn't bother testing anything. I thought about it but the dealer thought they could work it in quickly so I thought I'd just let them have at it.
I think it is statistically possible it could be just the brake fillaments on both bulbs but pretty darn unlikely, nevertheless it would be the place to start if you were going to do diagnosis.
I shouldn't be so lazy and do some of this stuff, but I bought a new one partly for the convenience of warranty. Got to spend my free time wisely you know, like riding the other bikes and net surfing. :wink:
 

·
Registered
Joined
·
441 Posts
Joe,

You are quite correct. You paid for a warranty and by golly you ought to use it if you need it.

The only reason I even thought both bulbs could be out is that years ago...
my car had no low beams all of a sudden. Hmm I thought, the lows couldn't BOTH have burned out at the same time. So I bought and installed a new dimmer switch. Guess what? I still had no low beams. Both bulbs had burnt out at the same time or very close to it.

Have the dealer fix you brake lights and ask them nicely to be quick about it.

Have fun!

Jeff
 
1 - 4 of 4 Posts
Top