StromTrooper banner

1 - 6 of 6 Posts

·
Registered
Joined
·
495 Posts
Discussion Starter #1
I was finally able to go out for a longer ride yesterday due to warm weather. This was my first "long" ride (3 hours)

Over the winter, I installed:
-Eastern Beaver fuse box
-Datel Voltmeter
-12volt "cigarette" plug
-Garmin 60CSX GPS

Everything goes into the EB fuse box.

While out on my ride, my GPS started turning off. Not sure what I was dealing with, I put 2xAA batteries in it to see if it was the unit or an electrical issue.

Once the batteries were in, I started getting "power disconnected" and the GPS switched over to battery power. I check the plug, it's properly seated.

Funny thing is, this seems to be happening when in first gear or at idle?Datal meter shows a steader 14.5 volts with the engine running.

I'm assuming maybe my wiring is wonky, I had to extend the stock power cable a bit, but I did a pretty clean solder job.

I use the GPS in my car, and i've never had any issues with it in 6 years.

any ideas where this gremlin is coming from?
 

·
Registered
Joined
·
1,849 Posts
I'm assuming maybe my wiring is wonky, I had to extend the stock power cable a bit, but I did a pretty clean solder job.
I think you're right. Look it over very closely. With the gps on, wiggle all the connections until you see the display get funky, you'll find it.
 

·
Registered
Joined
·
1,856 Posts
I have a 60CSX GPS as well... I used to use riding... I have it set for 12V power from the round plug in the back... (Directly into the EB fuse panel) I don't use 5V mini USB to power it ever... I noticed when the batteries are flat, the GPS keeps shutting off until I put fresh batts in... even though it is connected to 12V external power, it won't run on external power with dead batteries...
 

·
Registered
Joined
·
2,361 Posts
I have a 60CSX GPS as well... I used to use riding... I have it set for 12V power from the round plug in the back... (Directly into the EB fuse panel) I don't use 5V mini USB to power it ever... I noticed when the batteries are flat, the GPS keeps shutting off until I put fresh batts in... even though it is connected to 12V external power, it won't run on external power with dead batteries...
My Etrex does exactly the same thing on my ATV its mounted on. Needs good batteries all the time. If anything wiggles..either batteries or the plug into 12V, the GPS wants to shut down on me.
 
1 - 6 of 6 Posts
Top