StromTrooper banner

1 - 4 of 4 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
Hello everybody, glad to be back. I've been cage crazy for too long.

I did not find a new Vee. Rest in peace Strom you were good.

I am now the proud owner of a brand new 2010 Concours C14--blue of course. Rode her home from Mobile today, am breaking her in. Very preliminary impressions are ultra positive. Extraordinarily light on her feet for the weight. Holds beautifully through the corners I've tried. I'm limited to 4000 rpm's until 500 miles. That translates to right around 85mph indicated. 70 mph feels, well, sedate--I found myself thinking that I was just sort of purring along.

It had occurred to me that this bike might be a "Thor". But after riding her about 10 miles I called the wife and said there was no way she could be a Thor--she was an angel. Wife replied that she was a blue angel and there it was. Blue Angel she is. Took the wife for a ride tonight and she was pretty smitten, found her much more comfortable.

I have a question for Big B. I find that the engine does not turn over rapidly when starting. The dash indicates 14.2 volts. Does your C 14 turn over quickly when starting? My Strom would start instantly, the C 14 turns over several times before starting. Any comment?

Again, glad to be back!
 

·
Registered
Joined
·
813 Posts
Do you wait for the fuel pump to stop running before hitting the button? My '08 pretty much fires straight up if I wait for the pump.

I'm sure you'll love ya Connie - mine is a keeper (4 years so far).

But I'm sorry you had to get blue - don't you know that neutron silver is the fastest colour? :mrgreen:
 

·
Registered
Joined
·
155 Posts
Discussion Starter #3
I will make sure to listen for the fuel pump when I start her this morning. I hope that's what it is and not a real problem. I can't wait to ride this morning and I can't wait to get the initial 500 miles behind me.

I can't comment on the color/speed issue yet except to say that you are obviously incorrect.:green_lol:
 

·
Registered
Joined
·
155 Posts
Discussion Starter #4
FWIW the starting issue began to resolve itself at around 150 miles. The dealer said to just ride her and that any issues remaining after break in would be dealt with at that time.

Could it be as simple as tight new (big) engine?

Hmmmm.
 
1 - 4 of 4 Posts
Top