StromTrooper banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Just wanted to know if anyone has used K&S Flush Mount Turn Signals to replace the front OEM's. What do you think? Good quality? They mount without hardware (stick on). Do they hold well?

Just ordered some and now thinking about it, I guess I should have asked here first for recommendations to replace the existing OEM signals.

Recommendations welcome.

Thanks!!!
 

·
Registered
Joined
·
2,117 Posts
I'm not sure what brand mine are, but I've had tape-mount flush signals on my Strom since early 2005. No problem with them staying on.
 

·
Clever Title
Joined
·
515 Posts
Can't remember what brand mine are. One's stuck on with the included double-sided tape. The tape failed on the other side- probably my fault- so I stuck it on with RTV caulk. I think it's on there for good.
 

·
Registered
Joined
·
1,020 Posts
I've got Lockhart Phillips flushmount and they work fine for me. I got the ones with the integrated running lights because they were on sale, replacement light bulbs are a pain to find.

Rather than use tape to mount mine I preferred to drill through the body then nut & bolt them.

They're not really bright but they won't bust off in a tipover either.
 

·
Premium Member
Joined
·
4,451 Posts
I've got Lockhart Phillips flushmount and they work fine for me. I got the ones with the integrated running lights because they were on sale, replacement light bulbs are a pain to find.

Rather than use tape to mount mine I preferred to drill through the body then nut & bolt them.

They're not really bright but they won't bust off in a tipover either.
What # bulb is needed ?? Just curious.
 

·
Registered
Joined
·
1,020 Posts
What # bulb is needed ?? Just curious.
It is a Lockhart Phillips bulb, it's not available through regular channels; I can't remember the LP number.

The funny thing is it looks like something normal but it has indexed pins. I looked through a Sylvania buyers guide as well as a couple of other sources and couldn't find anything. After a bit of searching I discovered this is a common issue with people who buy these lights.
 
1 - 6 of 6 Posts
Top