StromTrooper banner

1 - 11 of 11 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
I am considering a DFO unit due to the great things I have been reading, but am a little anxious when it comes to splicing wires and such on my favorite ride. Anyone do this already that can post pics or detailed descriptions? I have considered the ones from Dale Walker (they come with connectors) but of course the price is higher. I read somwhere that techlusion may offer a military discount so I can probably get one for a great price through them, so no connectors for me. Thanks for the help guys.
 

·
Premium Member
Joined
·
569 Posts
I did an install on my 03 1000 and it went easy and smooth. Works great.

Only 4 wires to attach and small screw driver to tune in.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #3
Do you happen to have any pics of where/what wires to use. It may be different for an '06 but as long as I know about where to look I could probably figure it out. Am I making this harder than it is?
I haven't gotten a reply from dobeck performance about the military discount yet so I may end up getting the ones from Dale Walker anyway (which would be nice with the connectors and settings from his dyno tune) but we'll see.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
DFO unit should arrive today. After installing new exhaust I went ahead and orderd the techlusion from Dobeck Performance. For all you military folks, they offer a military discount on any one TFI product. I saved $90 ($150 for plug and play instead of 240, tap on ones are $100 with discount). Also, the plug and play box isn't on the website, it is part # FI-2054st.

Now for the question- I have been riding several times since the exhaust install and she seems to be doing fine, so where do I start to tune? In other words, how do I know what to do with it in order to tune it properly? I read somewhere that the recommended starting point settings are too rich and will foul plugs but that was only one person (not too much info available on the subject). Thanks for the help.
 

·
Administrator
Joined
·
17,100 Posts
DFO unit should arrive today. After installing new exhaust I went ahead and orderd the techlusion from Dobeck Performance. For all you military folks, they offer a military discount on any one TFI product. I saved $90 ($150 for plug and play instead of 240, tap on ones are $100 with discount). Also, the plug and play box isn't on the website, it is part # FI-2054st.

Now for the question- I have been riding several times since the exhaust install and she seems to be doing fine, so where do I start to tune? In other words, how do I know what to do with it in order to tune it properly? I read somewhere that the recommended starting point settings are too rich and will foul plugs but that was only one person (not too much info available on the subject). Thanks for the help.
Did you get it from Holeshot??? You should have gotten a recommended setting sheet if you did. If you didn't get it from Dale, maybe you can sweet talk him into helping you. You really only need fuel at the bottom or low rev range...maybe at idle too. I can't remember the setting pots on the DFO.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #7
I didn't get it from holeshot, basically so I could save 90 Jr. bacon cheesburgers (staple of college diet). I really wanted to so I could take advantage of DWs settings and tuning, but a discount pinched me in the wallet and I got this one and I am not expecting DW to give away his secret when I didn't buy it from him.

I basically need a tuning 101 on what to look for in rich or lean conditions. I can check the spark plug colors but want to keep that to a minimum while I get things tuned in. So, any tuning Yodas out there?
 

·
Registered
Joined
·
190 Posts
Discussion Starter #8
Alright, got it installed today. Took me about 3 hours to do it, including setting up the base settings and re-assembling everything/cleaning up. Experienced people will probably be faster but this was my first time going that far into the engine and it took time to figure things out. I have yet to ride it (will be in about 10 minutes) so no word on that yet.

Stuck the unit underneath the seat
http://i110.photobucket.com/albums/n110/bigtallguy75/SP_A0051.jpg

Here's a pick of all the wires attached at the injectors
http://i110.photobucket.com/albums/n110/bigtallguy75/SP_A0050.jpg

Injector wires before install. The connectors were a beeotch to get off, had to use angled needle nose pliars on the front one and then run a long flathead screwdriver up through the bottom to push on the release while I pulled with the other fingertips to get the back one off. Connection was easy though :rolleyes:
http://i110.photobucket.com/albums/n110/bigtallguy75/SP_A0049.jpg

http://i110.photobucket.com/albums/n110/bigtallguy75/SP_A0048.jpg



And I took the secondaries out while I was at it!

http://i110.photobucket.com/albums/n110/bigtallguy75/SP_A0052.jpg
 

·
Registered
Joined
·
51 Posts
Please post your DFI POT settings!

Hi,

Nice job on the DFI Install, I have a DL1000K5 and have ordered the DFI module from DFI, Jody there is super nice to work with and George (Tech) is an awesome guy on the phone, very helpful and sympathetic to the plight of the ever lean DL factory settings. Call them direct and they will give you the military discount, I saved $90.00! I created a monster by adding the 2 brothers cans and K&N filter, it stumbles and starves at 2.5K and again at 3.5K, I know the FI module will correct this over lean condition. Post your potentiometer settings for us!

Thanks!

Jer
 

·
Registered
Joined
·
190 Posts
Discussion Starter #10
Sorry for the delay, I was running a few tanks of gas through to get the mileage and be sure of my settings. As of now I have the idle pot turned off, accelerator at 2 o'clock, rpms (3rd pot) at about 6500 (6 1/2 o'clock), and the last one at 2 o'clock. I started with the idle pot at 2 o'clock but soon noticed black smudge building up in the tailpipes and figured it was too rich, so off it went. I played with the accelerator and found 2 o'clock setting to be where I feel the best improvement in acceleration. The last pot hasn't really required much playing with, I turned it off for a ride and noticed it ran worse in higher rpms so I spun it back on and left it.

My last tank with these settings was 33mpg, which is a 5-7mpg drop per my average before. I am sure that my riding has influenced this figure though, I have been accelerating really hard and riding faster lately to test things out, and have fun of course! I plan on pulling the plugs later to be sure I am not running rich. The black stuff on the tailpipes has me worried that I am still running rich, but I don't know for sure yet.

I plan on getting a K&N air filter later so that will lean things up some. I love the ease of adjustability with this thing, I just pop the seat off and turn the pot and I am good to go. The hard part is finding the proper settings. I am sure that things will be easier if you order from Dale Walker, but if not you will have something to do for a while;)
 

·
Registered
Joined
·
127 Posts
Here's another vote for the Techlusion. Finally added one to my otherwise stock (engine-wise) '04 DL1000. I didn't pull any plastic or the tank, only the seat, and tapped the wiring at the ECM. I set the pots at the suggested positions for the time being and the result is just what I wanted. Smoother acceleration, more low end grunt, and no more coughing. I shoulda done this about 24,000 miles ago!
 
1 - 11 of 11 Posts
Top