StromTrooper banner
1 - 4 of 4 Posts

·
Registered
Joined
·
541 Posts
Discussion Starter · #1 ·
Wondering what's up here: 2007 Wee with a Holeshot exhaust just added. I replaced the throttle position sensor at the same time, due to some strange cold-weather behavior that I had in the recent cooler months. When attempting to set the new TPS per the manual, I am running out of adustment range with its mounting screw. I can't get "-COO"; only "_COO", with hands off the throttle in dealer mode (bike not running). Twisting the throttle in dealer mode will make the bar rise. However, with bike running, in dealer mode, I can rev north of 4,000 rpm and the "_COO" won't change (I didn't hold it open too long, however).

So my question, has the new exhaust leaned things out to the point that the TPS is now not able to cope? I have a normal idle, and the bike revs up just fine, otherwise (and I don't know why I waited so long on the exhaust :yesnod:). I am prepping to do the SV cam swap, and I'll add the Power Commander III with Blair's Akra M4 custom map at the same time, probably next weekend. Still using a stock air filter, for now. I suppose a well-controlled Dremel tool could lengthen the TPS adjustment slot just a bit more, but I wanted to see what others have found, beforehand.
 

·
Registered
Joined
·
213 Posts
Does the old sensor behave like this too? I would have tried the old one first. The sensor itself seems to be the culprit. I cant see how a new pipe might affect it.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
The TPS's only variable is position. A throttle position has to be established for at least a half second before that position is mirrored by the -c00 dash. You may have a bad TP sensor or a marginal connector. I wouldn't try enlarging the slot.
 

·
Registered
Joined
·
541 Posts
Discussion Starter · #4 ·
Thanks; I'll go back in and try the old one again. If it behaves the same, I'll do the voltage check and inspect the connector. Did a 25 mile quickie ride - exhaust is really pleasing; not too loud at all for my tastes. Started, idled and ran very well in every instance. Can't wait to dig into the other mods planned.
 
1 - 4 of 4 Posts
Top