StromTrooper banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
258 Posts
Discussion Starter #1
I installed the skidplate today but the clamps that go around the crash bars are loose. I have tried loosening the bolts that attach the skidplate to the clamps and then retightened the allen screws on the clamps but they don't tighten around the crash bars. Is this normal? If not, any suggestions?
 

·
Registered
Joined
·
269 Posts
They should be tight.

When I got my skidplate, one of my clamps was tight, the other loose. I guess they make two sizes. Sounds like they sent you the wrong one.

Email them and they'll send you the right size.

Jamie
 

·
Premium Member
Joined
·
258 Posts
Discussion Starter #4
Rubber pads are on. I'm going to loosen everything again tomorrow and see if shifting things around a bit helps.
 

·
Registered
Joined
·
162 Posts
Did you order the correct front clamp for your crash bars
and if you did maybe they sent you the wrong ones.
 

·
Registered
Joined
·
127 Posts
Mine are very tight so I would second the other folks if you have the rubber pieces on, you might have received the wrong size hardware... of course if you don't want to send it back you could probably stop by Home Depot and pickup some mega-thick rubber to bridge the gap :^).
 

·
Registered
Joined
·
269 Posts
]if you don't want to send it back you could probably stop by Home Depot and pickup some mega-thick rubber to bridge the gap :^).
I didn't even send mine back. I called them. The guy asked me to read the numbers on them. He said I got the wrong part and mailed it to me.

Jamie
 
1 - 8 of 8 Posts
Top