StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
When I bought my 09 650 w/ABS the abs light was on, I realized this and noted that a line had been bypassed on the rear. All it did was disable the abs which is fine with me but I would like to have all systems functioning normally as designed. Anyone with previous experience with these abs controllers or other components? Just wondering if it was done because a part was very expensive. Any info and experience appreciated. Thanks.
 

·
Super Moderator
Joined
·
5,152 Posts
Not sure exactly about your description but many people here who regularly ride on dirt roads would rather not have the rear ABS working. The PO could have deliberately disconnected it, meaning that it may work fine when wired correctly.
 

·
Premium Member
Joined
·
3,463 Posts
There are a few cases of rear abs malfunction reported here on the forum. The parts are expensive, so many just bypass and keep riding.

A possible reason for failure is a lack of regular activation of the abs . Some have been sucessfull in getting it to function again by doing multiple abs engagements over a slippery surface such as grass. There is some type of piston the the abs that modulates the fluid flow and some suspect it just gets stuck from lack of use. You could do a complete fluid change, re connect it and give it a try.

When testing .....Remember.....If the rear does lock up....STAY on the rear brake until it comes to a stop. If you let go of the rear brake during a rear locked slide you can induce a high side crash. During a rear slide the back end of the bike will swing a bit from side to side....this is normal, don't fight it or let the brake up. Start testing at slow speed and work your way up to a higher speed only if you feel comfortable doing that. Slow speed activation most likely is all that is necessary to get it to start working again if the problem is a stuck abs module.
 
1 - 5 of 5 Posts
Top