StromTrooper banner

1 - 7 of 7 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
I have noticed when I start my Bike in Neutral...

Sounds like I have a little elf w/ a Hammer banging away in the engine case.. not very loud but you can here a very quick rap rap rap rap rap.

Pull in the clutch noise goes away.. let it out comes back.

When it's Hot it is still there but not as prevelant.

I know the 1000 has a chudder issue which is different...

Everything is fine... just noisey. Does not use oil. Clutch is adjusted properly... I could readjust it just to be sure.

I would say I am not hard on the clutch, I dont wheelie or spin up the rear in mud.

I have read a few posts with a similar comment and some reponders said the rivets in the baskets may have stretched.

Anyone else w/ a 650 suffer from this noise?
I have around 8500 miles.

Any Advice, Encouragement? Should I be worries bout something?
Do I need a new clutch or will I soon?

Thanks

Chris
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
Rotella

Synthetic (Blue Bottle)

5w-40

I feel confident it is a good oil for the bike.

I dont have any reason to think it would harm the motor or clutch
 

·
Registered
Joined
·
275 Posts
Discussion Starter #5
Stopped at my Freindy Neighborhood Suzuki Dealer today.

Had the Mech listen to the bike.
He naid the noise is OK... it's normal clutch noise, things may have continued on the break in and it has found a new level of worn in happiness.. perhaps that is why I notice it now but didnt earlier.

The noise is louder when it is cold.. But today it could still be heard while hot.

He Said he had an SV-650 that was louder than mine, and all was fine with that bike...

If it gets worse I may want to open it up and invesgtigate.. perhaps check the lash of the basket and the thickness of the disks to check for something out of whack, check the spec on the springs.... But he thought it wasnt necc. and said to ride it.....

So, I will be paying attention to it... if it gets worse I may open it.. but right now it's fine runs great, shifts fine.....

just a little tiny bit noisy.
 
1 - 7 of 7 Posts
Top