StromTrooper banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Had my bike in for the wiring harness recall about a year and a half ago, and they had to replace it. Ever since, the lighter plug hasn't worked. I checked it at the plug with it running - no power, removed the dash, checked the wires at the connector with it running - no power, finally checked the plug itself and I have continuity in the plug.

Anyone know if there is a spot downline somewhere where there is a connector that is could be loose? I pulled off all the plastic I could short of removing the tank - which I would hate to do, but might tackle over the winter if I had to.

Fuses seem fine under the seat... anyone know if it has it's own fuse hidden somewhere?

I have the Suzuki maint. manual, but it doesn't seem to think that DC plug system is even worth mentioning as I can't find it anywhere.

Thanks in advance!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
No! I didn't see them! That would be great if it was just a fuse haha! Where exactly is the fuse for this?

Thanks!
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,049 Posts
It's the first fuse in the #10 fuse box under the seat.

 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Ok, awesome, I'll switch it out! Thanks! I tried to discover which one the outlet was on from the maint manual, but no luck.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,049 Posts
The top of the box has a list of what the fuses are for.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Ok, awesome. That fixed it. It didn't look gone, but was. Thanks! I didn't realize "P-source" was for the DC plug!

Cheers!
 
1 - 7 of 7 Posts
Top