StromTrooper banner

1 - 11 of 11 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter #1 (Edited)
UPDATE: I am officially a knucklehead. The bike was in gear and wouldnt start even though I had the clutch pulled in. My vrod doesnt care but I forgot that the WEE has the safety feature kill switch with the kickstand down. DUH!


Guys,

I went out to the garage this morning and went to start the bike. There was a lot of noise so I didnt hear the fuel pump kick on when I flipped the switch. I went to start her and the headlights went dim and the bike didnt turn over. I thought it might have been the battery so I put a trickle charger on it. When I got home from work the charger was green and I went to start the bike. When I flipped the red switch, no fuel pump whine. Tried it again no dice. I removed the fuel pump relay just to check the connections and the connections looked ok. Still no dice. Any ideas? Is there a fuse maybe?

Thanks

Sean
 

·
Premium Member
Joined
·
1,516 Posts
Did you check the battery cable connections to the battery?

That is a really good place to start your search.
 

·
Registered
Joined
·
170 Posts
Been there, done that. Welcome to the club!
 

·
Registered
Joined
·
2,281 Posts
Ha ha! Doesn't the CHEC dealie come on for Knuckle heads?

No one has had a real problem yet that I can figure.
 

·
Registered
Joined
·
26 Posts
That sounds like something I would do. At least you were 'big' enough to follow up with an explanation.


Sent from my Motorcycle iPad app
 

·
Registered
Joined
·
14 Posts
Had a fellow strom rider ride up to me and flag me down in charlotte a few weeks back. There was a wreck a few miles up so traffic was pretty hectic, so I pulled onto the shoulder and he gave mine a good look over as i did the same for him. I got back on the bike and started it and evertime I went to put it into gear it would kill itself:furious:. I turned around and looked at the other stromer and he was pointing at the kick stand, which I forgot to put up:headbang:
 
1 - 11 of 11 Posts
Top