StromTrooper banner
1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey everyone, new to the site and could use some help. Bought a 2005 650 (54kmiles) and found rust in the tank. After treating the rust and resealing the tank I can't get any fuel flow. Does anyone have a clear picture or wiring diagram to see if I put pump back together correctly? I think its wired wrong or the pump is bad. And does anyone have a recommendation for aftermarket fuel pumps? Any help is appreciated.
 

·
Registered
Joined
·
5,650 Posts
The first thing to look at is to ensure you don't have CHEC displayed on the dash when the key is on.

Each time you turn the key on you should hear the pump prime/run for a second

Do you get that ?

The high pressure filter inside the pump will block up and that can be bypassed but first we need to know if the pump will run, you then do a fuel flow test as explained on this site.

I have had good results running the pump backwards it could be worth a try.

Fuel Pump Fix | StromTrooper
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The pump did not prime with the key and switch on. Hear a faint click and then nothing. Had drain hose hooked up to pump outlet and nothing came out. I didn't look at dash.
 

·
Registered
Joined
·
5,650 Posts
Do you have a CHEC displayed on the dash ?

Does your fuel gauge appear to be working ?
 

·
Registered
Joined
·
5,650 Posts
There is a plug with 3 wires in it to power the pump and the fuel gauge.

Ensure the kill switch is in the run position.

Open it up and test for power and earth on the bike side of the plug, each time the key is turned on you should get power to one wire for a second.

Sorry I can't remember the wire colour.

If you get that power the problem is with the pump if not the problem is with the bike.

I prefer a test light not a meter for power tests if you have one.
 

·
Administrator
Queensland, Australia
Joined
·
10,078 Posts
The pump did not prime with the key and switch on. Hear a faint click and then nothing. Had drain hose hooked up to pump outlet and nothing came out. I didn't look at dash.
Then your fuel pump is not working.

If you have CHEC on the dash check that the clutch lever switch is working and the kill switch is on - not off.

If you have no CHEC then check the wiring under your tank for a bad connection etc.
 

·
Registered
Joined
·
5,650 Posts
The clutch switch will not induce a CHEC or stop the fuel pump.
 

·
Registered
Joined
·
5,650 Posts
The clutch switch plays no part. you can ignore it till the pump runs each time the key is cycled..

The bike needs to be in neutral, the kill switch in the run position and the key on, that's it.

Have you checked the fuse
 
1 - 12 of 12 Posts
Top