StromTrooper banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have done some searching on this issue and found many others have it but I dont know if there is a CURE. Since mine is a first year and it has 73k miles on it, I dont know if its more prone to this type issue or if there is a Suzuki ECU flash update for it. I just bought the bike because I have wanted to try one of these and due to its mileage the price was right. So far only 3 things I dont really like. 1. it seems very top heavy. The effort needed to just lift it off the kick stand is a lot for this weight bike so i am a little concerned for it to see anything but tarmac. 2. it pops/backfires out the exhaust when i let off the throttle after aggressive acceleration. 3. is the real problem which is why I saved it for last. This bike when motor is cold idles at 3000-3400 rpms until the temp gauge has 2 full bars on the cluster and then it idles about 1200 rpms and there is nothing in between. when the bike is cold, I can take it out of the garage and not touch the throttle and just shift through the gears up over 50mph. there is no reason that idle speed should ever be over 2000 rpms and it should more gradually drop to that 1200 as it warms up. I have removed the body work and lifted the tank where i could watch everything operate. Everything is tight and no vacuum leaks which is why it idles fine warm. someone has been in there trying to fix the issue before because the throttle linkage isnt touching the throttle stops for either throttle body and you cant force them on down to throttle stop either. so I started it cold and watched that servo motor on rear throttle body that the computer uses to control this idle and it moves and obvious that is what is causing this high idle because shortly after that 2nd bar shows up on the temp gauge on cluster that servo moves and idle drops to normal bike is fine to ride after that but I hate that first 2 minutes well maybe only 1 minute but its a real nuisance and completely unnecessary for that thing to idle that high. I dont trust the suzuki dealer that is close by and so I wanted to see if its just something I have to live with or if anyone knows if Suzuki has a ECU flash update that would cure that issue or if I need to send the ECU off for aftermarket reflash. it currently has a PC3 on it but that is only fuel and shouldnt fix the idle issue but could be affecting that backfire issue. After it warms up though, I do enjoy the ride on tarmac but afraid that anything more than just smooth gravel will be treacherous.
 

·
Registered
Joined
·
1,859 Posts
In reply to your numbered query, some reading that may be of assistance:
1) check if the side stand is bent / shortened or that the bracket holding the side stand is not damaged https://www.stromtrooper.com/dl1000-2002-2012/416817-angle-lean.html
2) pops/backfires out the exhaust is normally a sign of the throttle boot issue https://www.stromtrooper.com/dl1000-2002-2012/328546-uneven-throttle-backfire-uneven-idle.html and https://www.vstrom.info/Smf/index.php/topic,2990.0.html
3) Have a look at https://www.vstrom.info/Smf/index.php/topic,7512.0.html
 
1 - 2 of 2 Posts
Top