StromTrooper banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I appear to be having some electrical issues with my 09 DL650. The majority of it appears to be related to operation of the turn signals.

1) When utilizing turn signals, the bike will sometimes die. Turning off turn signals, cycling the starter switch, and firing up the bike will cause it to start again seemingly without issues.

2) The turn signals illuminate slightly when applying the front or rear brake.

I am guessing I have a short somewhere-- anyone have any idea where these systems meet that may be the culprit? I have limited electrical experience and any attempts to point me in the right direction would be greatly appreciated.


Thanks!
 

·
Registered
Joined
·
377 Posts
Starting point : There's a large electrical connector inside the front cowling, left hand side. It's a bit known for connectivity/corrosion issues within. Take it apart & check.
 

·
Registered
Joined
·
740 Posts
harness woes

I appear to be having some electrical issues with my 09 DL650. The majority of it appears to be related to operation of the turn signals.

1) When utilizing turn signals, the bike will sometimes die. Turning off turn signals, cycling the starter switch, and firing up the bike will cause it to start again seemingly without issues.

2) The turn signals illuminate slightly when applying the front or rear brake.

I am guessing I have a short somewhere-- anyone have any idea where these systems meet that may be the culprit? I have limited electrical experience and any attempts to point me in the right direction would be greatly appreciated.

Thanks!
(I'm not gainsaying the above suggested connector check. (likely reinforcing it))

Your symptom #2 is a clear indication of a harness problem, and most harness problems are due to connection failure rather than wire failure.

I do not have a schematic for the 2009 Wee, or I would give you a list of connections to check, and advice as to how to do it. If you can find a schematic, (in the service manual, for example), I volunteer to come trouble-shoot your harness issue in exchange for a small favor, described at "Requesting a look at a few local V-Stroms". Please PM me if you like this offer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks all, I will check the connector under the left cowling today. As for the offer to help Trepidator, I am now across the country in DC but thanks anyways.

Pretty sure this may be related to the much harsher winter here than in the PNW. Salt everywhere, been buried in snow twice and had to be dug out, etc.
 
1 - 4 of 4 Posts
Top