StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Okay all you Strom tuning genius'. I have balanced the throttle bodies and smoothed out the non-clutch chudder but it took a couple of the adjustments to their limits. The sharpness of the throttle response has softened greatly, it smells rich and the gas mileage has fallen from low 50s to 38-41 mpg. Runs well but not great. Any ideas? The air filter is fine, fresh synthetic oil change. 10.6k miles. The clutch basket was done before I bought it. Not real satisfied. Anybody within about 4 hours of Goldsboro, NC that wants to take a look? Prove just how satisfying these are? Thanks for any ideas. And no, I have not yet tried changing or looking at the spark plugs. Tomorrow.
 

·
Registered
Joined
·
1,025 Posts
Sounds like whoever had it got a little "Fuel Happy" on the Yosh or Teka box... Might want to take it to a shop, have them reset the fuel map back to stock and and then make a minor tweak to the idle and low throttle settings...

Or, we could get on the list together (Charlotte) and get together for a weekend of tuning and riding when it gets here! I need to tweak mine a bit, too, so that could be good for both of us!
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
Thanks for the reply. I am in and out right (kind of cool in G-boro) and messing with it. It did okay until I started messing with to start with. The balance on the throttle bodies was WAY off. But it took several of the adjusting screws to the limits to even it out. And the idle way up. Now I am trying to get back to where it way before I "fixed" it. The local dealer's MAP box is broken and the independent guy they sent me to is out of town. So......
I pulled to plugs out. The front one is perfect mixture wise and the electrodes look like they just came out of the box. Clean and sharp edged. The rear one is wet and black. Okay. I will go from there and try and even it back out.
We can stay in touch and see about getting together to mess with them whether I get is squared away or not though. I am always up for a ride...all it has to be is not icy!

John
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
Well, putzing around in the cold and such I think I figured it out. I had put extension tubing on the throttle bodies for balancing. It appears to have given me an air leak. Caps back on the tubes and everything seems to have smoothed right back out. FYI & future reference....use better stuff that fits better.
 

·
Registered
Joined
·
1,025 Posts
hehehe... it is right chilly out, isn't it?

I was working (cleaning, actually) in my garage/shop today.. my buddy brought my old Intruder over for some maintenance so I needed more space. Poor me, right? :roll: TWO bikes chillin in the garage!

Sounds like you got yourself all figured out.. glad to hear it. I need to make a mamometer and do a TBS myself, that's about all that's left except for the clutch basket, which I'll likely hold off and do next fall.

But that doesn't mean we can't get together for a ride! We have a large NC group here on the site, check out the "new member from New Bern" thread in the Stromtroopers topic. We need to organize a good ride in the spring when the weather is better.

What? Did someone say barbeque? Sure, that sounds AWESOME! :lol:
 
1 - 5 of 5 Posts
Top