Problems installing GIPro on ABS Bike - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 11-20-2011, 09:38 AM Thread Starter
Stromthusiast!
 
BigMan73's Avatar
 
Join Date: Feb 2011
Location: Fair Lawn, NJ
Posts: 2,485
Garage
Problems installing GIPro on ABS Bike

I found a connector on the left side which has blue, pink and black white.


But it doesn't look like the connector that comes with the GIPro.
The GIPro is triangular, where as the OEM one is rectangular.


Any ideas?
Is this the right connector?
Perhaps the GIPro version I got wasn't designed for a 2011 ABS V-Strom?

2015 Triumph Tiger 800 XCx
2011 DL-650A, Now owned by another stromtrooper
-----------------------------------------------------
Stromputer - https://www.stromtrooper.com/dl650-2004-2011/73806-stromputer-alive.html
Stromtrooper Wiki - http://stromtrooper.wikispaces.com/
BigMan73 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 11-20-2011, 09:55 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I have a GIpro. It has a rectangular connector. It fits on the white connector in the center of the picture.


Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #3 of 12 Old 11-20-2011, 10:10 AM Thread Starter
Stromthusiast!
 
BigMan73's Avatar
 
Join Date: Feb 2011
Location: Fair Lawn, NJ
Posts: 2,485
Garage
Quote:
Originally Posted by greywolf View Post
I have a GIpro. It has a rectangular connector. It fits on the white connector in the center of the picture.
Thanks for trying to help.

I'm starting to think the GIPro have at least two versions of their gear indicator product ("ATRE").

Because the instructions in the box clearly say "Look for a pink/blue/black-white connector".
It is hard to see the exact shape of your connector, but the one I have on my bike is more of a 2x2 square.

If I'm not mistaken the pink wire is the one that carries the voltage signal of the current gear.
I read your other posts on this subject in this forum, and never understood why GIPro need to connect to the dealer mode connector. Maybe they started that way and moved to a much simpler (and cheaper) design?
They only need to need to manipulate (read and modify) the voltage on the pink wire to get all their functions working. Really no need to have any complex ECU communication for that.
The ECU just gets a different "fake 4th gear" voltage level for the ATRE.


This thread (very old! from 2006) clearly shows a triangular connector on the left side:
https://www.stromtrooper.com/v-strom-...tallation.html




My connector has the same wires but looks much different -it is 2X2, one 'port' is unused and has a black filling.

2015 Triumph Tiger 800 XCx
2011 DL-650A, Now owned by another stromtrooper
-----------------------------------------------------
Stromputer - https://www.stromtrooper.com/dl650-2004-2011/73806-stromputer-alive.html
Stromtrooper Wiki - http://stromtrooper.wikispaces.com/
BigMan73 is offline  
 
post #4 of 12 Old 11-20-2011, 10:25 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
You don't want an ATRE GIpro on a 650. It's the 1000 that has restricted gears other than 4th. The DS is the type to get. The ATRE does nothing for the 650 and is more expensive.

Have you even tried using the dealer mode connector? It's a direct plug in for the GIPro DS my ABS bike and works like a charm. It's closer to 1" square than 2". There were major wiring changes from 2006 to 2007 especially for ABS bikes. The dealer mode plug on non ABS models is under the left side cover.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #5 of 12 Old 11-20-2011, 10:29 AM Thread Starter
Stromthusiast!
 
BigMan73's Avatar
 
Join Date: Feb 2011
Location: Fair Lawn, NJ
Posts: 2,485
Garage
Quote:
Originally Posted by greywolf View Post
You don't want an ATRE GIpro on a 650. It's the 1000 that has restricted gears other than 4th. The DS is the type to get. The ATRE does nothing for the 650 and is more expensive.

Have you even tried using the dealer mode connector? It's a direct plug in for the GIPro DS my ABS bike and works like a charm. It's closer to 1" square than 2". There were major wiring changes from 2006 to 2007 especially for ABS bikes. The dealer mode plug on non ABS models is under the left side cover.
Indeed I don't want an ATRE - I got that as a present yesterday from a friend. But the instructions state that the ATRE can be disabled.

Can you please confirm that the pink wire in that square 2x2 connector is the GPS voltage?
I will probably sell the present, and instead go back to my original plans with my own display (My "Mk1B").
EDIT: That is I'm going to tap in with a PosiTap.

2015 Triumph Tiger 800 XCx
2011 DL-650A, Now owned by another stromtrooper
-----------------------------------------------------
Stromputer - https://www.stromtrooper.com/dl650-2004-2011/73806-stromputer-alive.html
Stromtrooper Wiki - http://stromtrooper.wikispaces.com/

Last edited by BigMan73; 11-20-2011 at 10:43 AM. Reason: PosiTap
BigMan73 is offline  
post #6 of 12 Old 11-20-2011, 10:34 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
If you already have a GIPro with ATRE, it will work. I can't tell you for sure the pink wire will read the gear position sensor voltage but it seems likely.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #7 of 12 Old 11-20-2011, 10:37 AM Thread Starter
Stromthusiast!
 
BigMan73's Avatar
 
Join Date: Feb 2011
Location: Fair Lawn, NJ
Posts: 2,485
Garage
Quote:
Originally Posted by greywolf View Post
If you already have a GIPro with ATRE, it will work. I can't tell you for sure the pink wire will read the gear position sensor voltage but it seems likely.
Perhaps there is someone with a 2011 Suzuki Manual that can confirm that pink wire?
I guess I can tap in with a Posi-Tap, worst case it is the wrong wire.
If I'm correct then a volt meter should show different voltage levels as I change the gears.

2015 Triumph Tiger 800 XCx
2011 DL-650A, Now owned by another stromtrooper
-----------------------------------------------------
Stromputer - https://www.stromtrooper.com/dl650-2004-2011/73806-stromputer-alive.html
Stromtrooper Wiki - http://stromtrooper.wikispaces.com/

Last edited by BigMan73; 11-20-2011 at 10:43 AM.
BigMan73 is offline  
post #8 of 12 Old 11-20-2011, 10:51 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I thought you were talking about a pink wire on the GIPro. The pink wire on the bike is the GPS wire used to determine the gear. The B/W is ground and the blue is the neutral indicator wire.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #9 of 12 Old 11-20-2011, 10:57 AM Thread Starter
Stromthusiast!
 
BigMan73's Avatar
 
Join Date: Feb 2011
Location: Fair Lawn, NJ
Posts: 2,485
Garage
Quote:
Originally Posted by greywolf View Post
I thought you were talking about a pink wire on the GIPro. The pink wire on the bike is the GPS wire used to determine the gear. The B/W is ground and the blue is the neutral indicator wire.
Thanks! great. So I didn't waste 1 hour of my time on tearing up the bike for nothing. I had to take off the left side and the whole OEM rack/Coocase rack to get there. I will PosiTap into the pink wire and close everything up.

Sorry for confusing you - the GI Pro has no pink wire. I meant only the stock one.

BTW: the blue wire is a design decision I don't get. Suzuki already know that the bike is neutral, from the pink wire..why have another redundant wire?

2015 Triumph Tiger 800 XCx
2011 DL-650A, Now owned by another stromtrooper
-----------------------------------------------------
Stromputer - https://www.stromtrooper.com/dl650-2004-2011/73806-stromputer-alive.html
Stromtrooper Wiki - http://stromtrooper.wikispaces.com/
BigMan73 is offline  
post #10 of 12 Old 11-20-2011, 11:20 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
It would take another sensor to get neutral from a specific voltage on the pink wire. Then the sensor would have to activate a relay to output a hot wire in neutral. A positive neutral contact in addition to the resistors for the gears in the GPS makes sense. You wouldn't want a dirty contact to take the voltage out of range and shut off the engine because the side stand was down or make the neutral light impossible to light. I'll very occasionally get a 0 (neutral) reading on the GIPro when the bike is in sixth.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome