GIPro Installed - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

 1Likes
  • 1 Post By Hmm
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-10-2019, 03:27 PM Thread Starter
Hmm
Stromthusiast!
 
Hmm's Avatar
 
Join Date: Aug 2018
Location: Republic Of Texas
Posts: 151
Garage
GIPro Installed

I installed a GIPro digital gear indicator on my 08 Wee and really like it. With just a quick glance now, I can see what gear I am in. I read some riders just say "Just read your tach and speedo needles and you don't need no stinking gear indicator!" but I like the quick glance at a large number in easy to read red (at least on my bike it is red.) I have also read that the ATRE function only works on Vees and not Wees. After riding today, I beg to differ. It seems to me that I have smoother power delivery in 2nd gear corners and actually had to be a bit more careful with adding throttle until I got used to it. Previously, it seemed like power was either off or on in those same corners. But then again maybe I'm just smoking some good stuff.
OCADVR likes this.

Bill
I been down around Houston Texas where the sun shines most of the time.

2008 Wee current
2014 Spyder RT LTD current

Past - Yamaha 850, Honda Nighthawk 700, Honda GL1200, Yamaha FJ1200, Suzuki Bandit 1200, Honda GL1800
Hmm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fiamm Horn Installed This Weekend Stromy Maintenance, Tech and Products. 7 02-28-2013 11:25 PM
Installed Rostra cruise control now speedometer doesnĚt work Rick54 DL650A - 2012-2016 12 10-04-2012 07:51 PM
Madstad Installed Yesterday doug44 DL650 and DL650A - 2004 to 2011 0 02-19-2012 12:27 PM
new wilber springs installed - fork brace still needed? mountainboy DL650 and DL650A - 2004 to 2011 8 09-28-2009 10:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome