horn help please - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-18-2009, 10:47 PM Thread Starter
Stromthusiast!
 
stevestrom's Avatar
 
Join Date: Nov 2008
Location: Langley, BC Canada
Posts: 186
horn help please

Alright, I installed (sort of) a Fiamm horn on my bike. I have a ground wire going from the battery to the horn and the power wire running to a relay. I have tied into the existing horn wires and run those to the relay as well.

Now according to everything that I have looked at this should make the new horn sound, but all I get is the old horn. I have checked and I have power at the relay from both the battery and the existing horn. I can make the relay 'click' when testing it, but still no horn.

Does the amperage of the relay matter? Do I have to wire the relay differently since the DL650 horn switch is on the ground wire?

Any help would be appreciated.
stevestrom is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-18-2009, 11:10 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
You must have it wired wrong. The bottom wires go to 85 and 86. The top wires go to 87 and 30.


Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html

Last edited by greywolf; 06-18-2009 at 11:13 PM.
greywolf is offline  
post #3 of 5 Old 06-19-2009, 08:10 PM Thread Starter
Stromthusiast!
 
stevestrom's Avatar
 
Join Date: Nov 2008
Location: Langley, BC Canada
Posts: 186
Fixed it!

Thanks for the reply Greywolf.

I did have it wired correctly but my ground wire from the original horn was loose. Works like a charm now!
stevestrom is offline  
 
post #4 of 5 Old 06-19-2009, 08:39 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Well, if the wire was loose, it wasn't wired correctly.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #5 of 5 Old 06-19-2009, 09:21 PM
$tromtrooper
 
Heavy's Avatar
 
Join Date: Feb 2006
Location: The gateway to Cottage Country, Ontario, Canada
Posts: 4,406
Didn't start a fire so he wasn't too far off.

Quote:
Originally Posted by greywolf View Post
Well, if the wire was loose, it wasn't wired correctly.

DL1000K6
Proud to be a Road Toad...Member #5
Heavy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome