PowerHub2 and SW-Motech Dual USB - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-08-2016, 06:44 PM Thread Starter
Stromthusiast!
 
Join Date: Jul 2015
Location: Stouffville, ON
Posts: 30
PowerHub2 and SW-Motech Dual USB

Have a PowerHub2 on my 2010 DL650 and I recently replaced the pre-existing toggle switch/12-V outlet with a SW-Motech Dual USB port from Twisted Throttle. Since I don't want the port constantly drawing power I simply hooked it up in the PowerHub2 and positioned the mini-fuse in the switched power position. To my surprise the USB port was powered up; key wasn't in the ignition.

I know the PowerHub2 is wired properly (black and red direct to the battery terminal, and yellow is posi-tapped to the brown wire in the tail light assembly for switched power). I have GPS, heated grips, horn, etc all running to switched power in the PowerHub2, and none of them power-up unless the ignition is on.

Any suggestions?
JoePalma is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-08-2016, 08:06 PM
Stromthusiast!
 
Hard miles's Avatar
 
Join Date: Jul 2012
Location: New Brunswick, Can
Posts: 500
1- You have a short on that part of the connection.
2- Try the fuse in the full time position, if it dosen't correct the problem you have a short.



Brian

[SIGPIC][/SIGPIC]
Hard miles is offline  
post #3 of 4 Old 03-09-2016, 05:34 PM Thread Starter
Stromthusiast!
 
Join Date: Jul 2015
Location: Stouffville, ON
Posts: 30
Tried the fuse in both positions, switched and constant, and the USB is constantly powered up regardless. Not sure what you mean by a short in that part of the connection. If I was shorting I'd expect the mini-fuse to blow


Sent from my iPhone using Tapatalk
JoePalma is offline  
 
post #4 of 4 Old 03-09-2016, 06:33 PM
Stromthusiast!
 
Hard miles's Avatar
 
Join Date: Jul 2012
Location: New Brunswick, Can
Posts: 500
Quote:
Originally Posted by JoePalma View Post
Tried the fuse in both positions, switched and constant, and the USB is constantly powered up regardless. Not sure what you mean by a short in that part of the connection. If I was shorting I'd expect the mini-fuse to blow


Sent from my iPhone using Tapatalk
If the fuse is set one way then the current flows all the time. If you set the fuse the other way current is allowed to pass depending on the ignition switch position. I would assume that there could be a short on the one side of the fuse that is ignition dependant therefore constant current as long as the fuse is in. The only way to be certain is to change the wires to another fuse for testing purposes.

Brian

[SIGPIC][/SIGPIC]
Hard miles is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome