Garmin 550 won't power on when... - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-28-2015, 08:50 PM Thread Starter
Stromthusiast!
 
soberjoe's Avatar
 
Join Date: Jul 2014
Location: Ottawa, Ontario
Posts: 140
Garmin 550 won't power on when...

Hey there everyone. I have a Garmin Nuvi 550 that I use daily on my travels, and I plug it into the 12v stock accessory on my 2014 Vee2. However, as is apt to happen - every once in a while the power plug vibrates out of the 12v socket on the dash, causing my GPS to power down if I don't notice it right away.
So, I thought I had a fix. I would use my GoPro 12v socket - USB adaptor, plug that into the 12v accesory socket, then connect the Garmin via a USB cable. Great, right?
Wrong.
The silly Garmin thinks its plugged into my laptop and won't power on. It remains in USB mass storage mode.

Any ideas or work arounds would be greatly appreciated

Joe

Today is the only day that truly matters. Here's hoping that yours is beautiful.
2001 Honda 750 ACE - written off May 25, 2014
2014 V-Strom 1000 - Purchased August 25, 2014 - first ride September 2, 2014
http://advjoe.ca/
soberjoe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-29-2015, 10:46 AM
$tromtrooper
 
dravnx's Avatar
 
Join Date: Oct 2012
Location: santa rosa, ca
Posts: 782
You can google around for a fix but it involves soldering a resistor into the micro usb connector and rendering it useless for anything other then a Garmin. Only Garmin cables work.

L2 DL650 Adventure


bike X miles=smiles
smiles bike=miles
miles smiles=bike.
It's simple math.
dravnx is offline  
post #3 of 3 Old 03-29-2015, 08:11 PM Thread Starter
Stromthusiast!
 
soberjoe's Avatar
 
Join Date: Jul 2014
Location: Ottawa, Ontario
Posts: 140
Quote:
Originally Posted by dravnx View Post
You can google around for a fix but it involves soldering a resistor into the micro usb connector and rendering it useless for anything other then a Garmin. Only Garmin cables work.
Actually I found a much simpler fix online. With the Garmin plugged into the usb port 12v adaptor in my accessory socket, as stated it immediately boots into usb mass storage mode. Once fully booted (green loading bar disappears) if the mini usb cable is unplugged from the back of the Garmin and then quickly plugged back in, the Garmin powers on as normal.

Problem solved

Joe

Today is the only day that truly matters. Here's hoping that yours is beautiful.
2001 Honda 750 ACE - written off May 25, 2014
2014 V-Strom 1000 - Purchased August 25, 2014 - first ride September 2, 2014
http://advjoe.ca/
soberjoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome