Amplirider install....how did you do yours? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-09-2008, 09:32 PM Thread Starter
$tromtrooper
 
AlbertaStrom's Avatar
 
Join Date: Jul 2007
Location: St. Albert
Posts: 76
Amplirider install....how did you do yours?

I'm about to install my new Amplirider but I'm at a loss about where and how I should install the 2 boxes.

Any one have a great idea?

I'd sure like to see how you did it....pics would be awesome
Thanks
AlbertaStrom is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-09-2008, 09:38 PM
Stromthusiast!
 
Sharkey's Avatar
 
Join Date: Dec 2007
Location: Portland, OR
Posts: 421
Send a message via Yahoo to Sharkey
I installed both boxes in separate pockets of my tank bag, I'm using my heated clothing plug in DC supply for power with an in line fuse. That way everything goes with me when I take the tank bag.
Sharkey is offline  
post #3 of 6 Old 03-09-2008, 09:51 PM
Stromthusiast!
 
Join Date: Apr 2006
Location: Pascagoula, MS,
Posts: 68
Ordered mine this morning, so I'm interested in what others did also.

Rick

'02 DL1000
Trickyrick is offline  
 
post #4 of 6 Old 03-11-2008, 10:48 PM
Stromthusiast!
 
Stainless's Avatar
 
Join Date: Jun 2007
Location: Antigo, WI
Posts: 57
I put the main box right behind the battery right before the under seat holder and the volume control attached to the center on the tank near the handle bars

1979 Yamaha 650 Special
2007 Silver DL650
Stainless is offline  
post #5 of 6 Old 03-13-2008, 11:04 PM Thread Starter
$tromtrooper
 
AlbertaStrom's Avatar
 
Join Date: Jul 2007
Location: St. Albert
Posts: 76
Quote:
Originally Posted by Stainless View Post
I put the main box right behind the battery right before the under seat holder and the volume control attached to the center on the tank near the handle bars
So your cables from the various devices are permanently running to the box? what kind of devices are you using it with? What about the headphones.....wire comes from under the front of the seat?
AlbertaStrom is offline  
post #6 of 6 Old 03-25-2008, 09:40 PM
Stromthusiast!
 
Stainless's Avatar
 
Join Date: Jun 2007
Location: Antigo, WI
Posts: 57
I only have my satelite input on it so it is permanently mounted. I ran an extension for the headphone jack and put it next to the volume control.

1979 Yamaha 650 Special
2007 Silver DL650
Stainless is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome