LED lamp going bad? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Techy World! GPS, Electronics, etc Electronics forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-13-2014, 06:09 PM Thread Starter
Stromthusiast!
 
jamessveta's Avatar
 
Join Date: Feb 2012
Location: Muskegon, MI
Posts: 289
Send a message via Yahoo to jamessveta
LED lamp going bad?

Hello,
I have a set of MM10 lights from Mondo Motos and one of the lamps have gotten noticeably dimmer than the other. Has anyone experienced this with any of their LED lamps? What would cause something like this? I contacted Mondo Motos but they say it is past the one year warranty. I would expect that an LED should last way beyond a year.
jamessveta is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-05-2014, 11:07 AM Thread Starter
Stromthusiast!
 
jamessveta's Avatar
 
Join Date: Feb 2012
Location: Muskegon, MI
Posts: 289
Send a message via Yahoo to jamessveta
UPDATE:

Not sure what was wrong with the LED light but I sent it back to MondoMotos and they replaced it for free. Now it's back bright lights! The customer service at MondoMotos was really great and I will definitely do business with them again!
jamessveta is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome