StromTrooper banner

stall

  1. DL650 and DL650A - 2004 to 2011
    Hi all, having a major problem, my 650 k7 has 150,000km under it's wheels, on one of my trips I ran over a speed bump and the bike started to go into the ignition sequence, the gauges going all the way up and down and engine revs up while doing so, the fuel pump "resets", if I don't catch the...
  2. DL650A - 2012-2016
    My 2012 wee has never had any problems before this. It (over the last year) would randomly ride weird where the acceleration would feel like I had the brake on 15% or so. Then, when I go to let off the throttle and shift, the engine dies while I am riding. I can rev up the RPM's high enough to...
  3. DL650A - 2012-2016
    I live in Arizona and leave my bike outside for work. Recently when it gets particularly hot outside the bike will die while driving! It feels like the power is giving out, its not jerky and electronics stay on. Typically the worst around 40 mph. Anyone know what can cause this behavior?
  4. DL1000 from 2002-2012
    hey guys, I have the following issues on my 2006 DL1000 with 99,000 miles! Fuel Pump Not Fully Priming When I turn the key to "on" the fuel pump only primes for half a second. (Not enough to start the bike) so I turn the key to off and then back to on. Almost like clockwork, the third time I...
  5. V-Strom Service & Maintenance Questions/Discussion
    Hey folks! I was out riding on Sunday doing something that involves a lot of stops and starts (Ingress if anyone knows it, if you don't, dont' worry about it). At one stop, I was idling for perhaps 3 minutes, and went to move off... now, my bike stalls easily - I chalk this to "I rode a big...
  6. DL650 and DL650A - 2004 to 2011
    Recently my bike (07 DL650 Non-ABS) began to bog down, stall, etc. (all the bad TPS symptoms). I adjusted the TPS with the engine at operating temperature and had the computer register -C00 at idle and then with the bar at the top at approx. 1800 rpm. It smoothed out my ride, but I still have...
  7. V-Strom Service & Maintenance Questions/Discussion
    Hi everyone, I have the same problem with some people here regarding the engine stall. And I've searched threads here, mostly the common problems are throttle SYNC, TP sensor or the air cleaner box not installed very well. I've done TP sensor adjustment on my K4 in the begining of 2010 but...
Top