StromTrooper banner

not starting

  1. Failure to Launch 2005 V

    Maintenance, Tech and Products.
    Okay, I have 2005 V and she was running like a champ yesterday. Today, after a bath I was unable to get her to start. I checked the engine cut off, as it's no the first or last time I've tried t run a bike with it off. After reading an older forum I plugged in my clutch line that had pulled...
  2. Alarm troubles - not starting

    DL1000A - 2014-2016
    Hello Strommers, I have the following problem: since last year I have my new Strom and indeed, it's a significant difference with the previous one (I had a DL1000 from 2004). On the looks we can discuss som hours because the old one with the two "eyes" had something special and now they went...
  3. She's not a happy little Wee

    DL650 and DL650A - 2004 to 2011
    Hi All, Riding to work on, lost all power on the freeway. (no loud bang, just massive drop), pulled over near off range and she stalls. Starts again with difficulty, but will not idle and stalls again. Eventually get home by holding the throttle wide open and idling at about 5-6K. Let he cool...
  4. Fuel pump relay circuit fault

    Maintenance, Tech and Products.
    Fuel pump didn't prime a couple of times but fault self corrected, now it,s stopped altogether. Get fault C41, relay has been checked, pump spins when 12v supplied direct. I'm no electronic expert but here's meter results; 12v measured for 3 seconds at Y/R wire on relay, where Y/R wire goes to...
Top