StromTrooper banner

electrical

  1. Electrical issue with starting

    DL1000 from 2002-2012
    Hey everyone, Lately I've been experiencing an issue where on occasion ill go to start the bike and it sounds as if the starter doesn't have enough power to turn over, then last second it does. Not a big issue in itself and probably normal. What has happened recently though is I'm coming back...
  2. Persisting Problem...Thinking I Might Need a New Wiring Harness???

    DL650 and DL650A - 2004 to 2011
    I posted a while ago about a problem my 2009 DL650 has been having for the past 2,000 miles. The VStrom has 38,500 total miles on it at this point. In short, the bike will suddenly experience a drop in RPM (extremely noticeable while riding) and then the power immediately returns in what seems...
  3. Time for a new battery

    DL1000A - 2014-2016
    I went out to start my bike this morning and it was dead. Completely dead. No lights, no clicking, nothing. I cared it full last week so there should have been something. SO... I pulled out my jump battery, hooked it up and all the lights came on and all the usually hums and gauge cycling. The...
  4. Auxilary lights intallation

    Maintenance, Tech and Products.
    Hello everyone, So i have a question, i recently purchased auxiliary lights for my dl650 2007 and hooked them up directly to the battery. They obviously work fine (i have also installed a switch), however i want: 1st - The lights to have power only when i switch the key to On. Right now anyone...
  5. Vstrom 650 RPM Fluctuations - Now Not Even Starting

    DL650 and DL650A - 2004 to 2011
    At this point in time I have no idea what could be wrong with my 2009 Vstrom 650. It currently has 37,500 miles, and I purchased it with 32,000 miles. At about the 36,000 mile mark, I began to notice the RPM gauge showing fluctuations of about 500 RPM. The needle would just not stay in place...
  6. Lost power to gauges and turn signals

    DL650 and DL650A - 2004 to 2011
    Hey guys, My battery still starts my engine fine, but I lost all power to my gauges and turn signals. Anyone ever experience this - is this likely a fuse issue? Thanks!
  7. Connector Short/Corrosion

    Maintenance, Tech and Products.
    Hoping to get some advice regarding an electrical fault I had this morning. Riding to work the gauge cluster started behaving oddly. Lights coming on and off, gauges reseting. The engine continued to operate as expected with no interruption. Eventually the odd behavior stopped and things...
  8. Help: Gas Gauge Sequentially Blinking, Doesn't Show Fuel Level

    DL650A - 2012-2016
    Hello! Long time member first time poster... After a long ride on my 2013 V-Strom 650 ABS I came back into my home town and headed to get fuel. Suddenly, I noticed my fuel gauge went from being solid bars to flashing sequentially from left to right. Even after turning the bike off and filling...
  9. Total Headlight Failure

    DL650 and DL650A - 2004 to 2011
    My headlights have gone out on my '05 strom. To keep the explanation simple, when the connectors to the headlights are UNPLUGGED, they have full voltage across the pins (I think the voltmeter showed ~12V across the low beam wire and ~2V across the high beam wire) on both connectors. However...
  10. 2011 battery not charging?

    DL650 and DL650A - 2004 to 2011
    Bought a 2011 a few weeks ago, rode it home from seller in the Bay Area down to Los Angeles, been riding it a bit for the past 3 weeks. PO put an LED voltmeter on, and most of the time at decent speeds it was a healthy green. Turning ignition on and starting it was never a problem. Had it out...
  11. Bike only starts when negative charge cable attached!

    DL1000 from 2002-2012
    Long time no see everyone. Guess my Strom and farkles have been holding up! Anyway... Just was out in the garage trying to get the Strom ('09 DL1000) going after winter hibernation and it wouldn't fire up for me. Long story short it's some sort of electrical issue. Fuses good, battery is...
  12. 09 DL650 Electrical Issues

    DL650 and DL650A - 2004 to 2011
    I appear to be having some electrical issues with my 09 DL650. The majority of it appears to be related to operation of the turn signals. 1) When utilizing turn signals, the bike will sometimes die. Turning off turn signals, cycling the starter switch, and firing up the bike will cause it to...
  13. Wiring meltdown under tank

    DL650A - 2012-2016
    Its become very apparent through searching the web that theres an emerging problem with the 2012 model year, and a particular area of the electrical system. Below the seat, on the left side of the bike, theres a huge wiring harness that sits directly on a ridge of the frame. At 21,000mi, my...
  14. Battery/Charging Issues

    DL1000 from 2002-2012
    Hey, I've been having battery/charging issues ever since I got my DL1000 last year. I took it to the shop when I first got it and asked them to check the battery/charger as just a precaution and they said both were fine. A few days later I went the gym on the bike, came out of the gym and the...
  15. CHEC indication, but it starts and runs okay

    DL1000 from 2002-2012
    My 02 Vee starts up fine, and runs, but on the starting sequence I get the CHEC message in the ODO area with five temp bars, then once I start it up, it goes away eventually and the temp gauge works fine. This is different than all the other posts I have read on CHEC, as folks get that and the...
  16. charging problem

    V-Strom Service & Maintenance Questions/Discussion
    ok, i've been pouring over threads in here went to start bike this morning 'clickclickclickclick' well poop jump it off car, starts up just fine, disconnect jumpers and it starts running funny and dies, jump it again and check voltage 14v while hooked up to car. disconnect car and it drops...
  17. Strange electrical issues with new 2012 V-Strom 650

    DL650A - 2012-2016
    I have a new 2012 V-Strom 650 with less than 1000 miles on it. I just had the initial service done last week. I'm having a strange, and troublesome, electrical issue that manifests itself in a couple of different ways. No aftermarket electrical add-ons yet. The most common issue occurs during...
  18. My V-Strom Died

    DL650 and DL650A - 2004 to 2011
    I just got an 06 Wee-Strom. I've had it a week today. I've been riding with no problems. This morning it's dead. I turn the key to "on", there's no sounds, guages don't spin up, no lights. I thought I must have drained the battery somehow and tried to jump it. Nothing. I checked the fuses - the...
  19. Speedometer erratic display

    DL1000 from 2002-2012
    Hey all, 09 DL-1000 with a sick speedometer. Only happens when the ambient temperature is hot. The needle fluctuates wildly with any transient in the bike voltage i.e. signal light, horn, shift low to high to low beam, etc.... When I come to a stop no the speedometer goes to it seems there...
  20. 2012 WEE Strom 650 Alternator output

    DL650A - 2012-2016
    Does anyone know if the 2012 GleeStrom has a higher alternator output than previous models? Still 400 watts max?
Top