Mitas E-07 - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Suspension and Tire Tech For all discussions related to your suspension and tire set-ups.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 07-13-2012, 11:51 PM Thread Starter
Stromthusiast!
 
2stroked's Avatar
 
Join Date: Mar 2012
Location: Nanaimo
Posts: 87
Mitas E-07

Installed the E-07's myself two days ago after getting some tips from Black Lab, front went easy, rear had to drive over the tire with my truck, even then didn't want to pop but got it. They both went on easy and both seated easy, didn't balance them, did a 6 hour ride yesterday and they are a little loud but nothing really bad and they weren't bad without balancing, did some gravel and seemed ok as well but I'm used to a 240lb bike not a 500lb bike.
Going to get Dynabeads this week and see what they feel like.
2stroked is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 08-17-2012, 06:10 PM
Stromthusiast!
 
BumbleBee's Avatar
 
Join Date: Jun 2006
Location: washington state
Posts: 503
update please

how about an update, been thinking of going with these this fall.

03' yellow dl1000 Rich's seat, custom built racks with ortieb drybags
givi crash bars, powercommander,mm spacers,SV slipper clutch
43t sprocket, speedohealer custom 04'+MpDesigns/madstad windscreen
BumbleBee is offline  
post #3 of 11 Old 08-26-2012, 03:33 PM
Stromthusiast!
 
glasswave's Avatar
 
Join Date: Feb 2012
Location: Wasatch Mnts, Utah
Posts: 438
Quote:
Originally Posted by 2stroked View Post
Installed the E-07's myself two days ago after getting some tips from Black Lab, front went easy, rear had to drive over the tire with my truck, even then didn't want to pop but got it. They both went on easy and both seated easy, didn't balance them, did a 6 hour ride yesterday and they are a little loud but nothing really bad and they weren't bad without balancing, did some gravel and seemed ok as well but I'm used to a 240lb bike not a 500lb bike.
Going to get Dynabeads this week and see what they feel like.
There is a little maker on the tire that you are suppose to line up with the wheel's valve stem port. I did this and they balanced perfectly. I'd recommend ride-on balancer. Seems to work better than beads, provides some flat protection and doesn't make a mess.

You're gonna love the e-07's. I'm very happy with mine.

[SIZE="1"]Trips:
Indian Himalaya:Gangotri-Shimla-Manali-Pavarti-Spiti-Leh-Kargil-Padum-Sringhar-Daramsala (3 mo.--2x)
Kazakstan-Krygyzstan-Tajikistan-Xin Xiang to Lhasa, Tibet on China 219!-Nepal (7 months)
Santiago, Chile to Ushuia Argentina and up to Cusco, Peru (7 months)
Peruvian Andes (3 months)
N Chile - Medellin, Colombia (3 months)
Cartegena, CO to N Chile (3 months)[/SIZE]
glasswave is offline  
 
post #4 of 11 Old 08-26-2012, 05:37 PM Thread Starter
Stromthusiast!
 
2stroked's Avatar
 
Join Date: Mar 2012
Location: Nanaimo
Posts: 87
Didn't know about the marker, I used Dynabeads and they seem to be fine.
I would think the rims would be out a bit as well as the tires.
So far so good with the tires and they seem to be wearing well, I have around 5000 km on them and they still look good even after my off road trip, the front did start leaking around the bead in three spots so I broke the bead used a brush and brushed slime on the bead, seemed to have stopped.
2stroked is offline  
post #5 of 11 Old 02-08-2013, 12:58 AM
Stromthusiast!
 
Join Date: Aug 2012
Location: Bellingham, WA
Posts: 105
Can you give a report on the EO7's on wet pavement? I seen lots of good reports, but not much comment on wet performance, and where I live, even the dry days often have wet pavement.
munsterlander is offline  
post #6 of 11 Old 02-08-2013, 02:00 AM
Stromthusiast!
 
ockerstrom's Avatar
 
Join Date: Sep 2009
Location: Windsor NSW Australia
Posts: 4,279
Mitas recall

Read this thread.

https://www.stromtrooper.com/general-...ds-merged.html

Read this recall notice.

Mitas

I was lucky because I only fitted a Mitas E07 to the rear of my Wee, I fitted a Mefo Explorer to the front [only because I have the Mefo's on my KLE500 and would have put one on the rear of the Wee but they don't make one wide enough for the rear rim, more than happy with the Mitas rear though].

The two different brands of tyre work really well together as they are both very similar in tread pattern and grip.

If the Mefo Explorer wears out too soon I will replace it with a Mitas E07 [all the suspect tyres should be out of the system by the time I need one].

The E07 looks like getting between 20,000 and 25,000km on the rear based on current tread wear measurements.
Based on my riding style and needs the Mitas is excellent, and very good value for money.

Ock. in Oz

I ride naked and unafraid.

Windsor (near enough)
NSW
Australia
ockerstrom is offline  
post #7 of 11 Old 02-08-2013, 07:37 AM
Stromthusiast!
 
Join Date: Oct 2012
Location: New Hampshire
Posts: 26
I'm really interested in a pair of EO7's for my Wee. It was rumored that there was going to be a distributor in the states soon. Anyone hear any recent news about this?
DANNAIR is offline  
post #8 of 11 Old 02-17-2013, 10:15 AM
Stromthusiast!
 
Join Date: Oct 2012
Location: New Hampshire
Posts: 26
To anyone that is interested, these: Mitas E-07 DAKAR Front Tire 110/80-19 TL DOT, are back in stock at MX1 Canada.
DANNAIR is offline  
post #9 of 11 Old 02-17-2013, 10:12 PM
Stromthusiast!
 
BumbleBee's Avatar
 
Join Date: Jun 2006
Location: washington state
Posts: 503
mx1 new stock after recall?

does anyone know if mx1 has post recall mitas e-07s instock?

03' yellow dl1000 Rich's seat, custom built racks with ortieb drybags
givi crash bars, powercommander,mm spacers,SV slipper clutch
43t sprocket, speedohealer custom 04'+MpDesigns/madstad windscreen
BumbleBee is offline  
post #10 of 11 Old 02-18-2013, 07:51 AM
Stromthusiast!
 
Join Date: Oct 2012
Location: New Hampshire
Posts: 26
I believe the non Dakar EO-7' will not be available until the end of March. I stand corrected: was just on MX1 CANADA' website and both EO7 non Dakars appear to be in stock. Best to check for yourself, here's their link: http://www.mx1canada.com/cart.php Sorry for any inconvenience.

Last edited by DANNAIR; 02-18-2013 at 04:46 PM.
DANNAIR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome