Hazard Lights - Right Hand Only - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance, Tech and Products. Maintenance questions, how to threads and product information/reviews.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-02-2019, 02:06 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Jul 2019
Location: Southcentral PA
Posts: 3
Hazard Lights - Right Hand Only

Happy Labor Day to All!
It's mostly a rain day in PA, so I'm troubleshooting an issue with my hazard flashers. While I do pre-ride light checks, I realize I don't check the hazards. That means I don't know if the issue existed before or after I installed the AdMore light kit for the Givi V46 top case. This mod was done about 2 months ago, with success, I think. Tail, brake, and both LH and RH signal lights work as expected. That's when I realized the hazard's only work on the RH side. I took the hazard switch apart this morning, to see if the contacts were dirty. (I had an issue last year with the turn signal switch working intermittently. Those contacts were "weathered" due to a lack of dielectric grease.) So I thought maybe the same thing was happening on the hazards. They seemed pretty clean, but I did the steel wool and dielectric grease just to be sure. Unfortunately, still only have the RH side working. With the hazards on and the LH signal, the signals blink like hazards. (At least it's a work-around, until I get the issue identified.)

I do have the factory service manual and see that checking continuity of the hazard circuit requires fuel tank and air box removal. I've done that once before, not a task to be taken lightly, so I thought I would ask for some opinions on the issue. Does this sound like a hazard switch issue or potentially a wiring issue for the AdMore kit?

I'm leaning toward the switch as the issue, since the LH and RH signals work fine independently. If it is the switch, I may just go with the above work-around, rather than replacing the entire switch assembly. If there isn't continuity on the hazard switch black wire, is that going to harm the rest of the LH signal circuit?

Thanks for any feedback offered!
2-OO's_letsgo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-03-2019, 01:46 AM
Stromthusiast!
Super Trooper!
 
Rolex's Avatar
 
Join Date: Feb 2013
Location: Sydney's East
Posts: 3,039
I would start with the added stuff.

Hazards usually work or they don't,

I've never seen it when only one side works unless it's a bad earth, but yours finds a earth when used as a indicator.

Will they work if you apply the brakes so the brake light illuminates ???

Set your hazards to on and use a test light (not a multi meter) to test for power at the ones that don't work, if the light indicates you have power it's more likely a earth problem.

Some of the 19 rides in my shed
2014 V2, Snoopy
2009 Wee, Pumbaa the pig
WR450F, The Blue Postie Bike
YZ250N smoker with rego, Stinky.
Yamaha MT09 (FZ09), The Scud missile.
Club Lead not Club Med.
He with the most toys wins.
Out of my depth in a puddle.
Live life on the edge you will see more that way.
Ridding a motorcycle keeps things in balance.
At the end of each trail and at the end of each day history is made.
Rolex is offline  
post #3 of 3 Old 09-08-2019, 01:41 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Jul 2019
Location: Southcentral PA
Posts: 3
I started at the switch with the test light, just to see if current was flowing there. Testing the back wire required lifting the switch assy out of the housing a bit. Test light showed current on all circuits, so I started reassembly. Then I noticed the hazards were working on both sides as well. Eureka! I guess fiddling around with the switch enough times, got the contacts lined up or worn in enough to work. Hazards will be on the pre-ride light check, just to keep the switch in use.

Thanks for the feedback Rolex!
2-OO's_letsgo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome