Instaling Cruise Control in 2018 DL650 - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance, Tech and Products. Maintenance questions, how to threads and product information/reviews.

 6Likes
  • 3 Post By Motor7
  • 2 Post By Rolex
  • 1 Post By realshelby
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 02-26-2019, 08:36 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Aug 2018
Posts: 1
Instaling Cruise Control in 2018 DL650

Hello guys,

Im trying to install the CCS100 cruise control in my 2018 DL650 Vstrom.

Followed the instructions, but system does not work.

Gone to the troubleshooting section of the installation manual and opened de cover on cruise and looked at the LED. Than:

a) Press Set button, and LED LIGHET properly. Seens ok, right?

b) Press Resume button, and LED LIGHET properly. Seens ok, right? But…

c) Step on the brake, but LED DOES NOT lighted. Seens something is NOT RIGHT, ok?

Don’t know if somebody can help giving any tips to fix it.

Any help is very appreciated !!!!

Thanks a lot.
Stormer is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 02-26-2019, 08:56 PM
$tromtrooper
 
Motor7's Avatar
 
Join Date: Mar 2014
Location: East Tennessee
Posts: 3,439
I am only familiar with the Rostra units, so here is my 2 cents. If any LED light bulbs or auto flashers are installed on the bike you will need a relay to make the CC work.
pvwheeler, EddieFL and Stormer like this.

15 DL650XT
"You do your own thing in your own time"
Motor7 is offline  
post #3 of 8 Old 02-27-2019, 01:56 AM
Stromthusiast!
 
Rolex's Avatar
 
Join Date: Feb 2013
Location: Sydney's East
Posts: 3,005
I agree with Motor, your LED brake light is the most likely cause of your problem and it will require a relay to bypass the LED.
pvwheeler and Stormer like this.

Some of the 19 rides in my shed
2014 V2, Snoopy
2009 Wee, Pumbaa the pig
WR450F, The Blue Postie Bike
YZ250N smoker with rego, Stinky.
Yamaha MT09 (FZ09), The Scud missile.
Club Lead not Club Med.
He with the most toys wins.
Out of my depth in a puddle.
Live life on the edge you will see more that way.
Ridding a motorcycle keeps things in balance.
At the end of each trail and at the end of each day history is made.
Rolex is offline  
 
post #4 of 8 Old 02-27-2019, 10:07 AM
Official Stromtrooper.com Sponsor
 
realshelby's Avatar
 
Join Date: Aug 2009
Location: Houston Texas
Posts: 5,039
The Rostra and Audiovox are the same unit.

Did you run the "diagnostics" test as prescribed in the manual?

There does seem to be some issues with the brake light not tripping the cruise control on the later DL's.
Stormer likes this.

'12 DL 650 '14 BMW R 1200 RT

WERKS modified clutch baskets for DL and SV 1000's.
The BEST in chudder control, noise control, and lasting durability! AVAILABLE HERE: www.werksparts.com

Have questions about the clutch in your DL or SV 1000? E-mail Terry [email protected]
realshelby is offline  
post #5 of 8 Old 04-17-2019, 12:15 AM
Stromthusiast!
 
Join Date: Aug 2011
Location: Northeastern Oregon
Posts: 81
Does this work on the 17', 18', & newer Wee ? If it does, can you post the entire setup as I have so far been unsuccessful. I have run the diagnostic and installed the brake light relay without success. I have installed 7 CCS-100's on sv & dl 650's & 1000's, Triumph 1050 Tiger and an FJR. PLEASE save me from this cruise control nightmare.
Kelrich is offline  
post #6 of 8 Old 04-18-2019, 10:43 PM
$tromtrooper
 
Motor7's Avatar
 
Join Date: Mar 2014
Location: East Tennessee
Posts: 3,439
Go back over everything you did. The first one I installed I could not get it to work and doubled checked all connections. After a couple of days of frustration I was just gonna yank the damn thing. Turns out the throttle bead had pulled out of the stupid little U clamp that comes with the Rostra to move the linkage. Some JB Weld fixed it and it's still working 6 years later.

So what did the diagnostic tell you?

15 DL650XT
"You do your own thing in your own time"
Motor7 is offline  
post #7 of 8 Old 08-20-2019, 08:53 PM
Stromthusiast!
Junior Trooper
 
Join Date: Aug 2017
Posts: 9
Hi Stormer.

I am trying install rostra CC in a 2018 wee XT a couple months and until know all effort was unsuccessful.
You were able to perform the installation ?

If you were able to install, could you provide the wiring diagram and what you found different in the installation compared to the wee 2 models?

I'll be very thankful.
wagnerjudice is offline  
post #8 of 8 Old 08-21-2019, 12:00 AM
Stromthusiast!
 
Join Date: Aug 2011
Location: Northeastern Oregon
Posts: 81
I mistakenly thought the CCS100 control pad worked with the Rostra. By the time I got the correct pad I probably fried something in the Rostra unit. Will be trying again with a new unit next month when things slow down. Most of the problems I've seen are with the LED taillight. The relay setup is critical as I found out on my 08' Tiger.
Kelrich is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rostra Electronic Cruise Control Install Instructions larolco Maintenance How-to 231 10-01-2019 09:59 AM
Rostra Cruise Control Alternate Wiring Strom Chaser V-Strom Modifications and Performance 26 07-02-2015 10:35 PM
Cruise control for SV650, cruise or speedometer-but not both rfulcher V-Strom Modifications and Performance 0 08-22-2010 10:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome