08 650 Won't Start - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance, Tech and Products. Maintenance questions, how to threads and product information/reviews.

 4Likes
  • 1 Post By notacop
  • 2 Post By Rolex
  • 1 Post By Gert
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-15-2018, 03:30 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Jun 2016
Posts: 1
Unhappy 08 650 Won't Start

Hi guys,
I was out for a beautiful ride, stopped for gas, went to start up and... no go. With ignition on, I get instrument sweep, fuel priming, but no headlights and start button does nothing.
Have checked clutch switch, side stand switch, took apart start switch and cleaned contacts. No luck.
Any thoughts? Which fuse(s) to check first??

Thanks,
Rob
HillyAir2 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-15-2018, 07:12 PM
Stromthusiast!
 
Join Date: Mar 2011
Location: Pasadna area
Posts: 13,916
I did that to myself once, it was the kill switch. I never intentionally use that switch and it took me a while to see it. I think it gives a CHEC light on the dash.
madstrom likes this.
notacop is offline  
post #3 of 6 Old 09-16-2018, 04:09 PM
Stromthusiast!
 
Rolex's Avatar
 
Join Date: Feb 2013
Location: Sydney's East
Posts: 3,009
Could be the start switch contacts or the big connector on the left side.

No headlights is the clue.

It is not a safety switch & the kickstand switch only plays a part if the bike thinks it is in gear, if you have a neutral light forget the kickstand switch as being the problem.

If the bike starts but stalls every time you select a gear it is the kickstand switch.
blaustrom and Fox like this.

Some of the 19 rides in my shed
2014 V2, Snoopy
2009 Wee, Pumbaa the pig
WR450F, The Blue Postie Bike
YZ250N smoker with rego, Stinky.
Yamaha MT09 (FZ09), The Scud missile.
Club Lead not Club Med.
He with the most toys wins.
Out of my depth in a puddle.
Live life on the edge you will see more that way.
Ridding a motorcycle keeps things in balance.
At the end of each trail and at the end of each day history is made.
Rolex is offline  
 
post #4 of 6 Old 09-21-2018, 01:16 PM
Stromthusiast!
 
Join Date: Oct 2014
Location: C
Posts: 60
On my 09 sometimes the connector to the clutch lever switch fall out, or are poorly connected. It is black ad sits about 2-23 inches inside from the clutch lever, on the handlebar.

~CW
croissant_warrior is offline  
post #5 of 6 Old 09-21-2018, 09:05 PM
Stromthusiast!
 
Rolex's Avatar
 
Join Date: Feb 2013
Location: Sydney's East
Posts: 3,009
Quote:
Originally Posted by croissant_warrior View Post
On my 09 sometimes the connector to the clutch lever switch fall out, or are poorly connected. It is black ad sits about 2-23 inches inside from the clutch lever, on the handlebar.

~CW
Yes that is very common but it will not stop the headlights working.

Some of the 19 rides in my shed
2014 V2, Snoopy
2009 Wee, Pumbaa the pig
WR450F, The Blue Postie Bike
YZ250N smoker with rego, Stinky.
Yamaha MT09 (FZ09), The Scud missile.
Club Lead not Club Med.
He with the most toys wins.
Out of my depth in a puddle.
Live life on the edge you will see more that way.
Ridding a motorcycle keeps things in balance.
At the end of each trail and at the end of each day history is made.
Rolex is offline  
post #6 of 6 Old 09-29-2018, 08:08 AM
Stromthusiast!
 
Gert's Avatar
 
Join Date: May 2013
Location: South Africa
Posts: 1,801
@HillyAir2 (Rob), have you managed to solve the starting problem on your K8 Wee? If so, what did you find to be the problem?
notacop likes this.
Gert is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine won't start, FI light comes on R-2 DL1000A - 2014-2016 49 07-08-2015 01:21 PM
CHK light and no start FLS DL650 and DL650A - 2004 to 2011 3 05-22-2014 02:13 PM
Hard to start, befuddeling Rogue Reaper V-Strom Service and Maintenance Questions and Discussions 4 11-22-2013 12:19 AM
2005 V-strom 650 won't start skiphunt DL650 and DL650A - 2004 to 2011 12 05-23-2010 09:35 PM
Help-wouldn't start before big trip Peterbob V-Strom Service and Maintenance Questions and Discussions 6 06-14-2008 03:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome