'06 Wee electrical gremlins fix - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance, Tech and Products. Maintenance questions, how to threads and product information/reviews.

 1Likes
  • 1 Post By Boit4852
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-19-2018, 02:43 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
'06 Wee electrical gremlins fix

My '06 Wee began to develop strange electrical issues several months ago that left me befuddled. Activating the turn signal would cause engine surging and sometimes stalling. As time progressed, using the brakes would cause the same issues. Finally, the engine starting system failed to work. By that I mean that when I would press the starter button, all electrical systems went blank. I suspected a grounding issue. I was correct. The culprit was the single conductor connector that originates about 8" from the negative battery cable. This is the B/W (~12AWG) wire that supplies a common ground from the battery. It even supplies the ground for the ECU. As I was attempting to replace both battery cables, I had a difficult time disconnecting this single-wire connector(B/W colored coded wire). Once I got it apart, I discovered that this connector was EXTREMELY corroded and was preventing a solid ground for all of the components. I had to cut this connector out since it was all but destroyed from corrosion and replaced it with a WAGO connector and fresh marine grade tinned wiring. Problem solved. I offer this experience in the hope that what I struggled through can help others avoid this frustration. No matter what motorcycle you own, if it is old and starts having strange electrical issues, check this ground connector first. Then, start looking for not only ground connection corrosion, but connections on the positive(hot) side. BTW, I also had to install a new starter relay. Any old motorized machine will suffer from electrical issues when connections haven't been cleaned regularly.
notacop likes this.

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster
Boit4852 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome