Valve Clatter - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance, Tech and Products. Maintenance questions, how to threads and product information/reviews.

 1Likes
  • 1 Post By MAZ4ME
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-17-2018, 10:26 PM Thread Starter
Stromthusiast!
 
Waltamatic's Avatar
 
Join Date: Sep 2009
Location: Conroe Texas
Posts: 33
Valve Clatter

Last December My FI light came on when I was leaving the house for a short ride. I narrowed the problem down to the Oxygen Sensor. Being short of ready cash (It was December after all) I promptly did a Google search, bought some resistors and bypassed that rascal. A quick trip around the block showed problem solved. Parked it back up ready for the next ride.

That next ride was today. Battery was dead.

I replaced the battery and cranked it up. It ran a little rough at first but settled down to a nice smooth familiar purr after a few minutes. Everything is good except, when I "get on it" the valves clatter like crazy. I'm not talkin a rattle here but a "loud A" clatter. My thoughts are that the clatter is due to the FI resetting, reading the OS bypass and coming up with some crazy fueling nonsense. If that is the case a new OS should fix my issue. Am I on the rite track or should I be looking elsewhere?

I would be super grateful for any insight that anyone can give.

If you keep doing what your doing your gonna keep getting what your getting.....
Waltamatic is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-17-2018, 10:43 PM
Stromthusiast!
 
Join Date: Feb 2017
Location: St. Louis, Missouri
Posts: 1,675
Hello!

You sure youre hearing valve clatter and not old gas causing spark knock under load?
Valves dont react to load, but you say when you "got on it" the clatter started. From your description of symptoms, for how long it's been since last run, I suspect a fuel issue.
Realize also that on 02 sensor is a "camera" of the engine control system. A too rich or too lean mixture can cause an 02 code to be set. The days of "Get a code, get a part" are a thing of the past. The code point toward the system, not the actual failure point.
Motor7 likes this.
MAZ4ME is offline  
post #3 of 5 Old 03-18-2018, 07:45 PM Thread Starter
Stromthusiast!
 
Waltamatic's Avatar
 
Join Date: Sep 2009
Location: Conroe Texas
Posts: 33
Well Sir, that just makes too much sense.

I've siphoned the tank as dry as possible today and will give it a couple gallons of premium tomorrow and see if that helps.

Thanks!!

If you keep doing what your doing your gonna keep getting what your getting.....
Waltamatic is offline  
 
post #4 of 5 Old 03-23-2018, 10:36 PM Thread Starter
Stromthusiast!
 
Waltamatic's Avatar
 
Join Date: Sep 2009
Location: Conroe Texas
Posts: 33
Quick update.

I replaced the fuel in the tank and it's running like a top.

Problem solved.

Thanks!

If you keep doing what your doing your gonna keep getting what your getting.....
Waltamatic is offline  
post #5 of 5 Old 03-23-2018, 11:47 PM
Stromthusiast!
 
Join Date: Feb 2017
Location: St. Louis, Missouri
Posts: 1,675
Glad to lend a hand!
MAZ4ME is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome