What am I missing? Can't reinstall windshield on 2014 Wee - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance How-to WARNING! If you follow these posts and something goes wrong - Stromtroopers is not responsible for any damages, etc. You assume all risk.

 1Likes
  • 1 Post By realshelby
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-01-2017, 11:31 AM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Feb 2017
Posts: 6
Garage
What am I missing? Can't reinstall windshield on 2014 Wee

I wanted to move my windshield up from the middle set of holes to the top. Removed it, and immediately lost one of the rubber nut/grommets that it screws into. Purchased replacements, but can't figure out what I'm doing wrong. First, it's a major pain trying to fit them in the hole without falling through before I can get the bolt started. But I managed to get that done and the shield is not being held tightly. The rubber grommet slides in and out, so I ended up just taking it all off. I'm actually happy without the screen, if it didn't look so goofy wo I'd like to get it back on. Any tips? Did I lose some other part that I don't realize? Doesn't seem like it should be so hard to adjust the screen height. Thanks for any help!
PhillyKev is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-01-2017, 11:58 AM
Official Stromtrooper.com Sponsor
 
realshelby's Avatar
 
Join Date: Aug 2009
Location: Houston Texas
Posts: 4,822
If the rubber grommet is sliding, it isn't being compressed by the threads on the fastener. Make sure they are the same size/thread pitch as the factory rubber well nuts. M5 x .8mm. If the rubber well nut is turning with the fastener it isn't going to tighten. Make sure each fastener runs in and out of the well nuts smoothly by hand before mounting the screen. If you have all the well nuts removed, start them onto the fasteners after putting them through the screen. Then carefully work each one into the appropriate hole in the cowl. Then tight by hand to snug them up. Much easier than trying to fish the fastener into each nut while they are in the screen! Eliminates pushing them through to never never land also.
wingstrom likes this.

'12 DL 650 '14 BMW R 1200 RT

WERKS modified clutch baskets for DL and SV 1000's.
The BEST in chudder control, noise control, and lasting durability! AVAILABLE HERE: www.werksparts.com

Have questions about the clutch in your DL or SV 1000? E-mail Terry [email protected]
realshelby is offline  
post #3 of 6 Old 05-01-2017, 01:24 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Feb 2017
Posts: 6
Garage
Thank you, that's what I was doing but it was still loose, but you made me think and I believe I must be putting the rubber grommets in backward. I was putting the wide, flared out end in first. But of course that would never tighten up all the way with the extra half inch pointing out. I probably just need to turn them around and like you said attach to the bolts through windshield first before pushing through the hole. Will try that, thanks!
PhillyKev is offline  
 
post #4 of 6 Old 05-01-2017, 10:03 PM
Stromthusiast!
 
spike55_bmw's Avatar
 
Join Date: Jan 2016
Location: Pennsylvania
Posts: 482
I have different length screws for the top holes versus the bottom (2015 650XT). Not sure why they didn't keep all the same length and minimize false starts (using the long ones on the bottom and then the short screws won;t work on top holes).
spike55_bmw is offline  
post #5 of 6 Old 05-08-2017, 03:54 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Feb 2017
Posts: 6
Garage
Yeah, I'm just a dummy. Was pushing the flared end in through the hole, thinking that's what held it in place. After reversing them, no issues. derp.
PhillyKev is offline  
post #6 of 6 Old 05-18-2017, 01:22 PM
Stromthusiast!
 
Xirdneh82's Avatar
 
Join Date: May 2017
Location: Missouri, USA
Posts: 34
Quote:
Originally Posted by PhillyKev View Post
Yeah, I'm just a dummy. Was pushing the flared end in through the hole, thinking that's what held it in place. After reversing them, no issues. derp.
In the future if you do it again, lightly coat the rubber with motor oil or at minimum wet it with your saliva. The grommets while pop in the hole much easier. Obligatory ”thats what she said".

Sent from my SM-T580 using Tapatalk
Xirdneh82 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome