installing carrier mat - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance How-to WARNING! If you follow these posts and something goes wrong - Stromtroopers is not responsible for any damages, etc. You assume all risk.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-22-2013, 07:05 AM Thread Starter
$tromtrooper
 
chirosyd's Avatar
 
Join Date: Feb 2011
Location: Adirondacks N.Y. beside Lake George
Posts: 2,178
installing carrier mat

I am in the process of de-farkling my '11 Wee as I will be trading it in early spring for a Vee2. I took off the Givi top box, and am having trouble re-installing the black rubber carrier mat. Any tricks out there to get those five wide black nipples through the carrier holes? Already tried liquid soap with no luck.
Thanks in advance.
chirosyd is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-22-2013, 11:51 AM
$tromtrooper
 
Stalky Tracker's Avatar
 
Join Date: Dec 2005
Location: Sconsin, USA
Posts: 3,734
Garage
Try coating each with a little liquid soap.

I prefer Softsoap Lavender & Chamonile. :mrgreen:

2020 Eastern V-Strom Rally (website) - May 14 - 17, 2020
__________________________________
2006 Suzuki V-Strom DL650K
1986 Honda Shadow VT700C
1974 Suzuki TM-250
1966 Triumph Bonneville T-120R
1965 Suzuki 80
Stalky Tracker is online now  
post #3 of 5 Old 12-22-2013, 11:56 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I used silicone spray for lube and grabbed the rubber spears by putting needle nosed pliers through the holes from the bottom.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
 
post #4 of 5 Old 12-22-2013, 01:18 PM
Stromthusiast!
 
Join Date: Jun 2013
Location: Portland OR
Posts: 621
I lubed mine with silicone grease & pulled them through with pliers. But one of the studs tore while pulling on it, anyway.

The rubber will be more pliable if it's warm. As you're pulling it through, try pushing on the top part.

2007 DL 650 with assorted upgrades
Solo is offline  
post #5 of 5 Old 12-22-2013, 03:55 PM Thread Starter
$tromtrooper
 
chirosyd's Avatar
 
Join Date: Feb 2011
Location: Adirondacks N.Y. beside Lake George
Posts: 2,178
Thank you all for your input. As per your recommendations, I purchased silicone lube, used pliers, broke one, used pliers, pushed and pulled, and now all is well. It looks stock as I had wanted. Now just hope my new Vee2 arrives before spring. I will be selling and giving away farkles from my '11 Wee as soon as I know my Vee2 is on its' way or has arrived.
chirosyd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome