A poll on charging system problems. Yes/No and what bike? - Page 22 - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Information Vault A place to post polls about members and their bikes as well as published information relevant to V-Stroms, for example, tech reports, dyno charts, brochures, articles etc.

View Poll Results: Please check as many answers as apply to you.
I had a charging system problem on a 2002 DL1000 9 1.51%
I had a charging system problem on a 2003 - 2012 DL1000 83 13.95%
I had a charging system problem on a 2004-2007 DL650 28 4.71%
I had a charging system problem on a 2008 - 2011 DL650 76 12.77%
I had a charging system problem on a 2012 - 2016 DL650 48 8.07%
I had a charging system problem on a 2014 - 2016 DL1000 1 0.17%
I had a charging system problem on a 2017 or later DL650 0 0%
I had a charging system problem on a 2017 or later DL1000 0 0%
Multiple Choice Poll. Voters: 595. You may not vote on this poll

 8Likes
Reply
 
LinkBack Thread Tools Display Modes
post #211 of 218 Old 07-19-2016, 10:54 PM
Stromthusiast!
 
Join Date: Jul 2014
Location: Antioch Ca.
Posts: 12
Quote:
Originally Posted by H.D.30-06 View Post
2008 dl 650. Bought the bike in 2014 with about 45,000 miles on it . At about 48,000 the stator went out . I had the stator rewound by Rick's Electrics. replaced the R/R with a series type . I also wired the out of the R/R to the battery on the advice of a mechanic/ friend. This worked well for just over 2 years. Now I'm having charging system problems again. Battery won't take a charge . But I'm sure that's not the cause of the problem.
I meant to say stator not state.
H.D.30-06 is offline  
Sponsored Links
Advertisement
 
post #212 of 218 Old 07-19-2016, 11:21 PM
Stromthusiast!
 
Sagebrush's Avatar
 
Join Date: Sep 2013
Location: J'ville, Alabama
Posts: 1,030
Always use OEM stators, the other stuff is crap usually. The aftermarket ones are short lived IMO. I've tried the electrosport crap myself, much rather buy a used one off eBay and roll the dice than that cheap junk.
Sagebrush is offline  
post #213 of 218 Old 07-19-2016, 11:48 PM
Stromthusiast!
 
Join Date: Jul 2014
Location: Antioch Ca.
Posts: 12
Not sure if the stator was the original or not. If it's bad again this time I'll definitely go with OEM. Thanks.
H.D.30-06 is offline  
 
post #214 of 218 Old 11-20-2016, 04:38 PM
Stromthusiast!
 
Join Date: Sep 2016
Posts: 13
I was out on a ride when my speedo stopped working and the engine started running rough. After nursing it home, I checked this site and found my problem. Bad stator and a few loose magnets on the rotor. I have two led fog lights and grip heaters. Time for JB Weld and a new oem stator.
Thanks for all of posts with all the expert advise and observations here!
PNWEric is offline  
post #215 of 218 Old 01-22-2017, 09:25 PM
Stromthusiast!
 
teevee's Avatar
 
Join Date: Jul 2010
Location: Miami/Managua
Posts: 1,296
Garage
to make the numbers more meaningful, there should be options for those not having had a problem. the poll only shows those who have had out of how many?????

'08 DR650, '07 DL1000
"And anyways, if they don't have motorcycles in heaven, I'd rather go to hell. I'm pretty sure they will have loads of them there." (deelip, 2016)
teevee is online now  
post #216 of 218 Old 01-22-2017, 10:13 PM Thread Starter
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
It used to have that but I removed it to allow more bike choices. The no problems vote was totally meaningless. People without problems didn't vote. Look at the poll on what bike is owned posted in the same forum. Fewer than 1000 people participated so far even though I have a link to there in my sig. This site has 46,561 members as I write this.
Big B likes this.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #217 of 218 Old 11-11-2017, 08:38 PM
Stromthusiast!
Junior Trooper
 
boroboy's Avatar
 
Join Date: Sep 2013
Location: Lanesboro MN
Posts: 3
Stator problem before recall.
boroboy is offline  
post #218 of 218 Old 07-05-2019, 10:38 PM
Stromthusiast!
 
royphotog's Avatar
 
Join Date: Sep 2011
Location: Fresno CA
Posts: 44
Garage
Stator problem, with two loose magnets. Replaced with a used OEM from eBay. (still waiting for delivery) No addition lights but do run headed vest and chaps during the winter.
royphotog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome