Help Please 2008 Canadian DL 650 only Two Spark Plugs? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 05-21-2011, 06:20 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2008
Location: Mississauga Ontario Canada
Posts: 594
Help Please 2008 Canadian DL 650 only Two Spark Plugs?

Hi Fellas
I am in the process of doing some maintenance.
My 2008 Canadian Wee appears to have only 2 spark plugs?
I thought they had 4 ?
Toto is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 05-21-2011, 06:59 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
There are four. You can see the two plugs on the sides. The others are buried in the center of each cylinder.


Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #3 of 11 Old 05-21-2011, 07:23 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2008
Location: Mississauga Ontario Canada
Posts: 594
Thanx Muchly...toto
Toto is offline  
 
post #4 of 11 Old 05-21-2011, 10:22 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2008
Location: Mississauga Ontario Canada
Posts: 594
Got em all...that front plug was a bitch...easier to put on my Scotts Damper.
BTW I did the Scotts at the same time as the air filter and plugs.
Very staight forward....no filing to be done.
Now I just have to put the cowling back on.
Toto is offline  
post #5 of 11 Old 05-22-2011, 12:11 PM
Stromthusiast!
 
honest bob's Avatar
 
Join Date: Feb 2009
Location: Courtice ontario canada
Posts: 1,564
Quote:
Originally Posted by Toto View Post
Got em all...that front plug was a bitch...easier to put on my Scotts Damper.
Very easy to get at if you first remove the rad and it's cowling. While you are in there (if not too late) check to see if the drain holes on the center plugs are open.

ADVENTURE, like beauty, is in the eye of the beholder.
The destination, can be the journey! Honest Bob
honest bob is offline  
post #6 of 11 Old 05-22-2011, 02:10 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2008
Location: Mississauga Ontario Canada
Posts: 594
Thanx for the tip...if I ever do it again I will remove the rad fro the frame.
I just undid it and swung it out a bit, tough job.
I put Iridiums in and don't plan to change 'em for quite a while.
Toto is offline  
post #7 of 11 Old 05-24-2011, 01:26 PM
Stromthusiast!
 
honest bob's Avatar
 
Join Date: Feb 2009
Location: Courtice ontario canada
Posts: 1,564
You may want to check the back of your rad to see that most of the fins have not been turned flat by your knuckles.

ADVENTURE, like beauty, is in the eye of the beholder.
The destination, can be the journey! Honest Bob
honest bob is offline  
post #8 of 11 Old 05-31-2011, 11:09 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2008
Location: Mississauga Ontario Canada
Posts: 594
Well, Bob, I did check....and sure eneogh...some of them did get bent...fixed as best I could...no overheating and it was hot as hell today.
Toto is offline  
post #9 of 11 Old 06-01-2011, 10:40 AM
pso
Stromthusiast!
 
Join Date: Jun 2009
Location: Eastern Shore of Maryland
Posts: 549
Toto, how did your plugs look and how many miles?
pso is offline  
post #10 of 11 Old 06-01-2011, 11:00 AM
$tromtrooper
 
Martin's Avatar
 
Join Date: Mar 2006
Location: NorOntario
Posts: 619
I just changed my plugs on the weekend... swinging the rad forward and using a bungy to hold it out of the way works fine *if* you use the spark plug tool provided with the bike... it's just the right length.

It took me less than an hour... mostly spent removing/reinstalling the tupperware. My 2005 only has two plugs though.

- Martin


2019 650X
Martin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome