Indicator/Turn Signal - I need help!!!! - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-21-2010, 06:00 AM Thread Starter
Stromthusiast!
 
Join Date: Feb 2010
Location: North East England
Posts: 14
Indicator/Turn Signal - I need help!!!!

Morning all,

I need some help with the indicators on my lovely yellow 1000. She has so far been a trusty steed and has covered 10,000 miles in under six months without issue.

However, yesterday the LHS indicators packed up. No flashing. No dashboard light. Nothing. Got home and checked the bulbs and they both looked fine. I swapped them over with the RHS and the result was the same. Dead on the LHS. On the way into work this morning I rode with the LHS switched on for a few miles to see if it was a loose connection and whether theyd come back on however briefly, But again nothing.

I genuinely am the worlds most useless electrician, so Im after some advice.

If the problem was one of the indicator units, would that prevent both on that side functionining?
Is it likely to be a fuse (i.e. are the different sides fused seperately)?
What should I try next?

Any advice would be appreciated. Hand signals are not only quite scary, they are also deeply uncool...

Ta,

Phil.
westyorkshirephil is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-21-2010, 09:36 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Both sides run off the same fuse and same flasher. The switch itself is a likely suspect. Another possibility is the connector at the end of the wiring harness coming from the switch housing. It will be behind the radiator shroud. The hot wire for the left side signals is solid black.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome