Squeaky Brakes - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-11-2010, 08:10 PM Thread Starter
Stromthusiast!
 
Glazier2000's Avatar
 
Join Date: Dec 2007
Location: NorCal
Posts: 295
Squeaky Brakes

This summer I replaced the brake pads on the Wee.
Then last week, I notice a squeak coning fron the front as I applied brakes.
Hmmm...must be a small rock on the pads, so removed calipers and sprayed brake cleaner all over including pads and reinstalled....no joy.
The damn squeak is STILL there.
The rotors show no abnormal scoring or wear.

Anyone know what else I could do??

2007 DL 650A
2012 Super Tenere
Glazier2000 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-11-2010, 08:43 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Did you replace the shim pads #14 and #15 or did you discard them with the old pads?


Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #3 of 4 Old 09-12-2010, 12:15 AM Thread Starter
Stromthusiast!
 
Glazier2000's Avatar
 
Join Date: Dec 2007
Location: NorCal
Posts: 295
[QUOTE=greywolf;605617]Did you replace the shim pads #14 and #15 or did you discard them with the old pads?

I'm sure I used the original (chrome thingies) with the new pads.

2007 DL 650A
2012 Super Tenere
Glazier2000 is offline  
 
post #4 of 4 Old 08-24-2014, 11:53 AM
Stromthusiast!
 
Sconde's Avatar
 
Join Date: Mar 2013
Location: Home: Vancouver BC. Current: Portland OR
Posts: 135
Even 4 years on this post is still saving lives.

Thanks for helping me figure out where I messed up.


Sent from Motorcycle.com Free App

'12 650 ADV in White: Oxford heated grips, 12v socket x2, BarkBuster Storms, Pivot Pegz, OEM Aluminum cases and top box, OEM crashbars,
Sconde is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome