Hepco Becker side rack installation - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 06-14-2010, 02:27 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Jun 2010
Location: Canada
Posts: 3
Hepco Becker side rack installation

I just got caribou side cases with hepco becker racks for the DL650. I've got them completely installed except for 1 of 4 attachment points on each side that mount behind/under the passenger foot pegs. the nuts currently attaching the passenger footpegs appear to be welded on as seen from the other side and need to be removed to attach the fourth part of the rack.

has anyone installed these racks and dealt with this problem?
maddaddam is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-14-2010, 02:39 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I think it mounts differently than you think it does. Try contacting Adventure Motostuff if you don't get a clear answer here.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informa...-you-have.html
greywolf is offline  
post #3 of 8 Old 06-14-2010, 02:39 PM
Stromthusiast!
 
WEE4ME's Avatar
 
Join Date: Dec 2008
Location: London Ontario Canada
Posts: 263
Send a message via Skype™ to WEE4ME
I just looked at mine, the rack mount attaches on the front of the passenger peg mount not the back. So it sits between the passenger peg and the mount.
WEE4ME is offline  
 
post #4 of 8 Old 06-14-2010, 05:46 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Jun 2010
Location: Canada
Posts: 3
i'm not sure if i'm understanding you correctly or vice versa, so check out this link for 2 photos. http://s1013.photobucket.com/albums/af258/maddaddam/

the luggage rack bracket needs to be attached along with the passenger foot peg and therefore the bolts need to be removed. the nuts holding them in place on the other side, however, appear to be welded on.
maddaddam is offline  
post #5 of 8 Old 06-14-2010, 06:24 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Just take the bolts out. The nuts are welded to the frame but the bolts aren't. The adapter fits between the footpeg bracket and the frame.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informa...-you-have.html
greywolf is offline  
post #6 of 8 Old 06-14-2010, 06:39 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Jun 2010
Location: Canada
Posts: 3
hahahaha ok i'm an idiot, thanks for setting me straight
maddaddam is offline  
post #7 of 8 Old 06-14-2010, 06:57 PM
Stromthusiast!
 
WEE4ME's Avatar
 
Join Date: Dec 2008
Location: London Ontario Canada
Posts: 263
Send a message via Skype™ to WEE4ME
I have the same setup for over a year now and they work great. Another thing I like about them is that you the cases have a large flat surface place souvenir stickers on.
WEE4ME is offline  
post #8 of 8 Old 06-14-2010, 11:38 PM
Stromthusiast!
 
dtalk's Avatar
 
Join Date: Apr 2008
Location: The Northwet, U.S.
Posts: 2,275
Quote:
Originally Posted by maddaddam View Post
has anyone installed these racks and dealt with this problem?
No, but I had plenty of other problems. Those racks are a horrible design. There is no excuse for a design that requires me to prop my rear rack up at an angle, causing all the bolts to bear upon their mating surfaces at an angle, and looking really stupid.

I bought them, and promptly returned them. Yeah, the Touratech setup costs more, but in this case, there's a reason ... fit and finish.

Sorry ... rant off.
dtalk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome