Rostra Cruise Control Intermittent Failure - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 10-23-2017, 06:41 PM Thread Starter
Stromthusiast!
 
Join Date: Jul 2010
Location: Louisville, Kentucky
Posts: 72
Rostra Cruise Control Intermittent Failure

I've had a Rostra cruise control on my 2014 DL650A for about 3+ years. I use it all the time, even on short rides if i get a little open road.

Lately, starting on a recent long trip, I've had some intermittent failures. Every day it would start up and engage cruise as soon as I asked for it, working flawlessly. At some point later in the day ... almost every day of a two week trip ... when I tried to reset (using "set" as opposed to "resume") it after disengaging, it would fail to re-engage. A few times it even dis-engaged on its own as I was riding down the road.

Generally when this failure happened, I would turn off/turn on the unit and try again with no luck. Then I would turn it off and leave it off for a long while. Later when I came back to it, most of the time it would work fine.

Any ideas? Is this just the switch failing due to being exposed to the elements?

Chris
2014 DL650 - Red
Former bikes ...
2005 DL650 - Red ... totaled Aug-2013
2007 Yamaha V-Star Silverado 650 - Black & Blue ... sold
1984 Honda Magna V45 (700 cc) - Black ... sold
2001 Honda Elite 50SR (hopped up to 72cc ... woo hoo!!!) - Red ... sold
TVdoorknob is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-23-2017, 07:39 PM
Stromthusiast!
 
Rolex's Avatar
 
Join Date: Feb 2013
Location: Sydney's East
Posts: 3,005
The first thing I would check because it is easy.

Is check you have enough slack in the rear brake light switch to ensure the brake light is not staying on (very common on bikes) and ensure your right boot is not switching the brake light on accidently.

Some of the 19 rides in my shed
2014 V2, Snoopy
2009 Wee, Pumbaa the pig
WR450F, The Blue Postie Bike
YZ250N smoker with rego, Stinky.
Yamaha MT09 (FZ09), The Scud missile.
Club Lead not Club Med.
He with the most toys wins.
Out of my depth in a puddle.
Live life on the edge you will see more that way.
Ridding a motorcycle keeps things in balance.
At the end of each trail and at the end of each day history is made.
Rolex is offline  
post #3 of 7 Old 10-23-2017, 08:06 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Intermittent electrical problems are the hardest to diagnose. Checking the brake light is a good idea as the unit gets its ground connection through the brake light filament. A loose or failing filament or the brake light coming on will cancel the cruise control. See if replacing the bulb helps.

You coul go through the LED response tests but they will only help when the problem is active.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informa...-you-have.html
greywolf is offline  
 
post #4 of 7 Old 10-24-2017, 12:39 AM
$tromtrooper
 
larolco's Avatar
 
Join Date: Oct 2006
Location: Langley, BC, Canada
Posts: 2,411
FWIW, it was water getting into my switch that spelled the end of mine.

I never did bother to replace it since I've rarely felt the need to use the CC after doing the Iron Butt which prompted its installation.

The brake light theory sounds like a good place to start. Then the switch if you suspect water intrusion. Another possibility is a bad wiring connection but that's a bit more work to trace. I think I'd probably re-do all the connections if I didn't see something else obviously wrong. PITA though.

DL1000K6 Two wheels good; four wheels bad.
DRZ400SK17

Last edited by larolco; 10-24-2017 at 12:44 AM.
larolco is offline  
post #5 of 7 Old 10-24-2017, 01:07 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I had two wiring problems. The first was a broken wire to the control pad. The soldered connections moved wth the steering and the motion caused a wire to break at the end of the solder flow. The other was a bad solder joint. I wrapped a CC wire around a stock wire and when I soldered it I only got the solder on the CC wire.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informa...-you-have.html
greywolf is offline  
post #6 of 7 Old 10-26-2017, 11:15 AM Thread Starter
Stromthusiast!
 
Join Date: Jul 2010
Location: Louisville, Kentucky
Posts: 72
Thanks for the suggestions. Will try the brake light and probably get a switch ordered as well.

While I'm at it I may as well pick up an Omni-Cruise or Vista Cruise to carry as a back up.

Chris
2014 DL650 - Red
Former bikes ...
2005 DL650 - Red ... totaled Aug-2013
2007 Yamaha V-Star Silverado 650 - Black & Blue ... sold
1984 Honda Magna V45 (700 cc) - Black ... sold
2001 Honda Elite 50SR (hopped up to 72cc ... woo hoo!!!) - Red ... sold
TVdoorknob is offline  
post #7 of 7 Old 10-26-2017, 02:18 PM Thread Starter
Stromthusiast!
 
Join Date: Jul 2010
Location: Louisville, Kentucky
Posts: 72
Does anyone know if the Rostra cruise control switch is just sending a resistance signal to the main unit? I would be interested in building my own CC controls (in an effort to get larger buttons and more weather resistance) but if it's any more complicated than resistors, it could be out of my sandbox.

Chris
2014 DL650 - Red
Former bikes ...
2005 DL650 - Red ... totaled Aug-2013
2007 Yamaha V-Star Silverado 650 - Black & Blue ... sold
1984 Honda Magna V45 (700 cc) - Black ... sold
2001 Honda Elite 50SR (hopped up to 72cc ... woo hoo!!!) - Red ... sold
TVdoorknob is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome