Durability of the Admore lighting kit? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 Old 09-13-2016, 06:41 PM Thread Starter
Stromthusiast!
 
Thighrod's Avatar
 
Join Date: Dec 2015
Location: Canada's East Coast
Posts: 118
Garage
Durability of the Admore lighting kit?

Hello gents,

Does anyone have long term experience with any of the Admore LED products?

I ordered a light kit for my Givi E52 top box this spring and it has quit working (for no apparent reason). A bunch of back and forth has already taken place with Admore, and with the help of my multimeter, I think I've nailed down the problem to an issue in the part of the harness that steps the voltage down to the proper levels to illuminate the LEDs in the topbox.

Although I loved the product (when it was working), I am worried about its long term prospects. Given the cost (my kit was $220+ Canadian), I expected at least a few trouble-free years.

I have been instructed to send the offending harness back to Admore, where, upon receipt, they will examine and decide whether they will replace under warranty, if they don't determine that I caused the issue (somehow). I'm a little bummed that it'll likely end up being at least a couple more weeks or so before I get my enhanced rear visibility back, but we'll see what happens.

Any other Admore experiences out there/long term reports?

Thanks
Thighrod is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 09-13-2016, 06:57 PM
Stromthusiast!
 
SECoda's Avatar
 
Join Date: Apr 2015
Location: Southern Missouri - Ozarks
Posts: 13,133
Well mine is about 20 months old and still working on a Givi V47. I have the full tail light set. I take it you are past the 12 month warranty? I would call them anyways.

Customer Service

Toll Free: 1-877-564-8100

2014 Suzuki V-Strom 1000 ABS (Candy Daring Red)
2017 Kawasaki Versys-X 300 ABS (Graphite Grey)
2013 Suzuki V-Strom 650 ABS Adventure (sold)
SECoda is offline  
post #3 of 16 Old 09-13-2016, 07:15 PM Thread Starter
Stromthusiast!
 
Thighrod's Avatar
 
Join Date: Dec 2015
Location: Canada's East Coast
Posts: 118
Garage
No, I bought mine in the February, it's been in use since April. Still under warranty.
Thighrod is offline  
 
post #4 of 16 Old 09-13-2016, 08:11 PM
Stromthusiast!
 
eagleeye's Avatar
 
Join Date: Jun 2015
Location: Richland County Wisconsin
Posts: 1,056
Garage
Givi E-52

I'll be watching this thread as I just put one on my Givi E-52. If you haven't sent it in yet, you might check the fuse/connections, and terminal block to see if everything is where/how it is supposed to be.

2009 Suzuki DL650
2005 Yamaha RSTD
2002 Triumph Bonneville
1980 Yamaha XS650 chopper

The Best Bike is the Bike You Like
eagleeye is offline  
post #5 of 16 Old 09-13-2016, 09:15 PM Thread Starter
Stromthusiast!
 
Thighrod's Avatar
 
Join Date: Dec 2015
Location: Canada's East Coast
Posts: 118
Garage
Yes, thanks, I already tested the voltage of each connector at every joint. Looks like the harness, the flat vinyl wrapped area between the distribution block and the connector that goes into the topbox, is the culprit.
Thighrod is offline  
post #6 of 16 Old 09-13-2016, 09:37 PM
Stromthusiast!
Junior Trooper
 
Join Date: Sep 2015
Location: Vancouver B.C.
Posts: 8
I had an admore light kit for my Givi top box, sorry can't remember which one, but it worked for 5 years just fine. I sold the bike so I don't know if it is still working. I have the light bar on my Glee and it's been working fine for 12 months now. I ride all year too.
coracle is offline  
post #7 of 16 Old 09-13-2016, 10:22 PM Thread Starter
Stromthusiast!
 
Thighrod's Avatar
 
Join Date: Dec 2015
Location: Canada's East Coast
Posts: 118
Garage
That's great to hear. Maybe I just got unlucky with mine then. Thanks for replying.
Thighrod is offline  
post #8 of 16 Old 09-13-2016, 10:27 PM
Stromthusiast!
 
Mulewright's Avatar
 
Join Date: May 2011
Location: West Monroe, La. U.S.A.
Posts: 223
Garage
After installing a 'double' kit in my V47 (top & bottom positions) I can say they have good warranty & most helpful customer support for the 1st year... under warranty.
They replaced the std. kit lights 2 times & the 'controller' 1 time.
The 'lid' mounted lights don't tolerate dampness at all well.
2nd Controller is doing fine also mounted under the seat... so far.
The 3rd set of lid mounted lights went bad 3 mos ago, the non std.'kit' lights supplied are still working just fine.
NOT the results I expected for the cash outlay.
I have other options I am checking out...

[B][I]~ Stretching the Limits of Performance & Good Taste ~[/I][/B]
Mulewright is online now  
post #9 of 16 Old 09-13-2016, 10:54 PM
$tromtrooper
 
Stalky Tracker's Avatar
 
Join Date: Dec 2005
Location: Sconsin, USA
Posts: 3,977
Garage
I've been running the Admore SMT light bar for about 15-16 months. No issues and works great.

2020 Eastern V-Strom Rally (website) - May 14 - 17, 2020
__________________________________
2006 Suzuki V-Strom DL650K
1986 Honda Shadow VT700C
1974 Suzuki TM-250
1966 Triumph Bonneville T-120R
1965 Suzuki 80
Stalky Tracker is offline  
post #10 of 16 Old 09-14-2016, 10:23 PM
$tromtrooper
 
chicago's Avatar
 
Join Date: Oct 2009
Location: bishop, CA
Posts: 3,365
I have used their products without issue in the past though I did have a light bar that had some non-working leds. A photo of the problem and a new one was on the way. My opinion is they are a first rate outfit. Good luck.

14 tooth for me
chicago is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome