Side Stand Switch - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-13-2008, 05:58 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: May 2008
Location: Wylie, TX
Posts: 2
Side Stand Switch

Guys,

I have a DL650 that won't start and the starter relay is not initializing when you turn it on. However it will start when I jump between the two poles on the relay. And I have checked the starter relay and it's good. I've checked the side stand relay, gear position switch, and kill switch. I suspect that I have a bad side stand switch because I don't get any continuity between the two wires to the switch, but the voltage doesn't test out like it provides in the service manual.

Has anyone dealt with this issue and if so, is the side stand switch usually the culpret?

Thanks,

Rick
Uturnrick is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-13-2008, 06:02 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Check the clutch switch. It's the usual culprit. Loose connectors at the clutch lever pivot switch account for 90% of such problems. If the side stand was bad, you couldn't start it by jumping the solenoid.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #3 of 3 Old 05-13-2008, 06:29 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: May 2008
Location: Wylie, TX
Posts: 2
That was it Pat,

A loose connection at the clutch switch. I pressed it in all the way and that did it.

Thanks a bunch,

Rick
Uturnrick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome